2

I've scoured the Internet and asked on numerous forums for 2 months looking for an answer to this problem and only gotten 1 response that had nothing to do with the problem.

The DHL shipping module refuses to work in all latest releases of Magento.

Even on a fresh install of 1.7, 1.8, and 1.9 and only enabling it without configuring any other setting it refuses to work and keeps spitting this error in return for all versions:

2014-07-24T13:12:40+00:00 DEBUG (7): Array ( [0] => String could not be parsed as XML [1] => The response is in wrong format. [__pid] => 25540 )

Simply enabling it and nothing else DHL never comes up as a shipping option and only reports that it's not available.

There is nothing on the Internet specifically about this issue which is blowing my mind because it's bugged in all of the CE releases. It can't be that no one is using the DHL shipping module.

closed as off-topic by Marius, Keyul Shah, brentwpeterson, Amit Bera, Matthias Zeis Nov 23 '14 at 15:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced OR seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Marius, Keyul Shah, brentwpeterson, Amit Bera, Matthias Zeis
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What do you mean by "only enabling it without configuring any other setting"? – mbalparda Jul 24 '14 at 13:32
  • Enabling it for checkout in the admin without supplying any additional info. – user3474767 Jul 24 '14 at 13:43
1

It seems you are trying to use the DHL modules without any credentials. In order to make it work you should ask DHL for the credentials.

I cant find official documentation, but here and here is something similar for Magento Go. Give it a read and you will notice you are missing all the information from DHL and the DHL module does not work without the proper credentials.

  • It's the same result with or without credentials. – user3474767 Jul 24 '14 at 13:56
  • Here is the error produced in system.log Warning: SimpleXMLElement::__construct() [<a href='simplexmlelement.--construct'>simplexmlelement.--construct</a>]: ^ in /app/code/core/Mage/Usa/Model/Shipping/Carrier/Dhl/International.php on line 810 – user3474767 Jul 24 '14 at 13:57
  • So you are stating you have the DHL credentials and you followed each step to gain access to their endpoint and still nothing? Do you have a guide about the process to get the DHL credentials for me to read? – mbalparda Jul 24 '14 at 13:58
  • Yes I have the credentials provided by DHL api support. I don't know anything about a guide. – user3474767 Jul 24 '14 at 13:59
  • The DHL error logs keep returning the XML string with no indication of any problem which is weird. The first error states that Array ( [0] => String could not be parsed as XML which is leading me to guess there is something bugged with the XML portion of it. I have no clue. – user3474767 Jul 24 '14 at 14:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.