With the upgrade to Magento ver. 2.3.3, there are some major changes to the inventory system which are great, however, I use an external ERP system to manage my stock levels are they are causing issues with products becoming out of stock.

I have a big issue with the "Reservations" and "Salable Quantity" features. As I use an external system to manage my stock, they become redundant to me and I would like to disable them (unless you provide me with a more effective solution).

My issue looks as follows:

  1. I have 2 products of SKU-A
  2. Customer buys 1 product SKU-A
  3. The stock for SKU-A is Stock=2 | Salable Quantity = 1 (1 reserved)
  4. My ERP system sends a stock update (There is only 1 item of SKU-A as a customer just purchased one.)
  5. The stock for SKU-A is now Stock=1 | Salable Quantity=0 (1 reserved)
  6. Item is out-of-stock

Can anyone think of a good solution to the above problem?

  • 1
    I have te same, did you find a solution? Commented Jan 20, 2020 at 11:07

1 Answer 1


If your ERP stock update happens often enough, and your website isn't creating large amounts of sales in the gap between updates, you can just disable the reservation step

EITHER by making the Magento orders "shipped" at the point the orders get passed on to the ERP (there are modules with "auto ship on invoicing" for example)(that doesnt disable the step is just moves to the next step, so that functionality is still there for other needs)

OR by turning off the reservation, which you can do in Configuration > Catalog > Inventory. Set No to "Decrease Stock When Order is Placed" "Set Items' Status to be In Stock When Order is Cancelled" and "Automatically Return Credit Memo Item to Stock"

These options are not suitable if your setup is complex and things change fast, then you either need to put some "margin" in the stock you make available on the website or modify your ERP integration workflow so to play nice with "un shipped" orders, perhaps by triggering an order status update before the stock update.

  • In the end, I have set No to "Decrease Stock When Order is Placed". That did the trick for me, at least temporarily until I have a proper fix with my ERP.
    – Greg
    Commented Jan 27, 2020 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.