2

I have selected Allow Countries as Saudi and one another as you can see in below screenshot https://prnt.sc/qjyde9

the issue is that while edit customer record it's showing the different countries as selected from the dropdown in admin general settings.you can check the selected country list in above screenshot. here is showing a different countries. https://prnt.sc/qjyg3f

3

In This vendor/magento/module-ui/Component/Form/Element/AbstractOptionsField.php

Line no. 73

From :-

$config['options'] = array_values(array_replace_recursive($config['options'], $options));

To :-

$config['options'] = array_values(array_replace_recursive($options,$config['options']));
| improve this answer | |
  • 1
    Thanks for helping it worked for me. – Vikas kalal Jan 6 at 12:08
0

This solution is also worked for me

Please open the below path file.

vendor/magento/module-customer/view/adminhtml/ui_component

open customer_address_form.xml and remove below code from line number.194

<formElements>
   <select>
       <settings>
           <options class="Magento\Directory\Model\ResourceModel\Country\Collection"/>
           </settings>
      </select>
 </formElements>

Remove the above code from the file and move this file to a local folder like below.

app/code/Magento/Customer/view/adminhtml/ui_component/customer_address_form.xml

After remove that you will see your selected country into customer address edit in M2

| improve this answer | |
0

It's a bug in Magento https://github.com/magento/magento2/issues/25218 Please go there and show support for it being fixed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.