Server: CentOS 7 PHP: 7.3.13 Litespeed: Enabled Magento: 2.3.3

I was attempting to run some updates via composer when I received an error about my PHP being too high.

enter image description here

I attempted to upgrade php-cs-fixer from v2.13.3 to v2.16.1 (which supports PHP73) - however, this failed for the same message as below (under Problem 1). Server was downgraded to PHP7.2 but when running the command

composer update friendsofphp/php-cs-fixer

I received a message that there was nothing to update??

I ran the following command to see if it was a composer error

composer diagnose

which pointed out I was running composer 1.8.9 (which has now been updated to 1.9.1).

Any idea how I can upgrade php-cs-fixer to allow me to run composer commands on PHP7.3

  • You should check this with Mageplaza or use the Magento packaging. – Arno Vande Cappelle Jan 2 at 15:37
  • The example is with mageplaze - but all composer updates don't seem to work when on php7.3. I compared my composer.json and composer.lock files to those off a fresh Magento 2.3.3 download and they differ vastely. – newbie_rebel Jan 2 at 15:47
  • If I create copies of my servers composer.lock and composer.json, and override them with the downloaded magento 2.3.3 zip then I get errors of the following ,,, - magento/magento2-functional-testing-framework 2.3.14 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0|~7.2.0 -> your PHP version (7.3.13) does not satisfy that requirement. ,,, – newbie_rebel Jan 2 at 15:51
  • 1
    Problem Solved: I copied over the composer.json and composer.lock from the Magento-CE-2.3.3-2019-09-26-03-30-45.zip and then ran composer update (seems to have updated a lot of modules). – newbie_rebel Jan 2 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.