0

After migrating data from Magento 1 to Magento 2 When I click on customers in admin area it gives this error

enter image description here

{"0":"Type Error occurred when creating object: Magento\Eav\Model\Entity\Attribute\Source\Config","1":"#1 Magento\Framework\ObjectManager\Factory\Compiled->create() called at [vendor/magento/framework/ObjectManager/ObjectManager.php:56]\n#2 Magento\Framework\ObjectManager\ObjectManager->create() called at [vendor/magento/framework/Validator/UniversalFactory.php:36]\n#3 Magento\Framework\Validator\UniversalFactory->create() called at [vendor/magento/module-eav/Model/Entity/Attribute/AbstractAttribute.php:642]\n#4 Magento\Eav\Model\Entity\Attribute\AbstractAttribute->getSource() called at [vendor/magento/module-customer/Model/AttributeMetadataConverter.php:68]\n#5 Magento\Customer\Model\AttributeMetadataConverter->createMetadataAttribute() called at [vendor/magento/module-customer/Model/Metadata/CustomerMetadata.php:87]\n#6 Magento\Customer\Model\Metadata\CustomerMetadata->getAttributeMetadata() called at [vendor/magento/module-customer/Model/Metadata/CustomerMetadata.php:119]\n#7 Magento\Customer\Model\Metadata\CustomerMetadata->getAllAttributesMetadata() called at [vendor/magento/module-customer/Model/Metadata/CachedMetadata.php:85]\n#8 Magento\Customer\Model\Metadata\CachedMetadata->getAllAttributesMetadata() called at [vendor/magento/module-customer/Ui/Component/Listing/AttributeRepository.php:83]\n#9 Magento\Customer\Ui\Component\Listing\AttributeRepository->getList() called at [vendor/magento/module-customer/Ui/Component/Listing/Columns.php:102]\n#10 Magento\Customer\Ui\Component\Listing\Columns->prepare() called at [vendor/magento/framework/Interception/Interceptor.php:58]\n#11 Magento\Customer\Ui\Component\Listing\Columns\Interceptor->___callParent() called at [vendor/magento/framework/Interception/Interceptor.php:138]\n#12 Magento\Customer\Ui\Component\Listing\Columns\Interceptor->Magento\Framework\Interception\{closure}() called at [app/code/Amasty/Orderattr/Model/ResourceModel/Value/Plugin/Order/Grid/Columns.php:58]\n#13 Amasty\Orderattr\Model\ResourceModel\Value\Plugin\Order\Grid\Columns->aroundPrepare() called at [vendor/magento/framework/Interception/Interceptor.php:135]\n#14 Magento\Customer\Ui\Component\Listing\Columns\Interceptor->Magento\Framework\Interception\{closure}() called at [vendor/magento/framework/Interception/Interceptor.php:153]\n#15 Magento\Customer\Ui\Component\Listing\Columns\Interceptor->___callPlugins() called at [generated/code/Magento/Customer/Ui/Component/Listing/Columns/Interceptor.php:26]\n#16 Magento\Customer\Ui\Component\Listing\Columns\Interceptor->prepare() called at [vendor/magento/framework/View/Layout/Generator/UiComponent.php:164]\n#17 Magento\Framework\View\Layout\Generator\UiComponent->prepareComponent() called at [vendor/magento/framework/View/Layout/Generator/UiComponent.php:161]\n#18 Magento\Framework\View\Layout\Generator\UiComponent->prepareComponent() called at [vendor/magento/framework/View/Layout/Generator/UiComponent.php:142]\n#19 Magento\Framework\View\Layout\Generator\UiComponent->generateComponent() called at [vendor/magento/framework/View/Layout/Generator/UiComponent.php:103]\n#20 Magento\Framework\View\Layout\Generator\UiComponent->process() called at [vendor/magento/framework/View/Layout/GeneratorPool.php:81]\n#21 Magento\Framework\View\Layout\GeneratorPool->process() called at [vendor/magento/framework/View/Layout.php:343]\n#22 Magento\Framework\View\Layout->generateElements() called at [generated/code/Magento/Framework/View/Layout/Interceptor.php:89]\n#23 Magento\Framework\View\Layout\Interceptor->generateElements() called at [vendor/magento/framework/View/Layout/Builder.php:129]\n#24 Magento\Framework\View\Layout\Builder->generateLayoutBlocks() called at [vendor/magento/framework/View/Page/Builder.php:55]\n#25 Magento\Framework\View\Page\Builder->generateLayoutBlocks() called at [vendor/magento/framework/View/Layout/Builder.php:65]\n#26 Magento\Framework\View\Layout\Builder->build() called at [vendor/magento/framework/View/Layout.php:253]\n#27 Magento\Framework\View\Layout->build() called at [vendor/magento/framework/View/Layout.php:875]\n#28 Magento\Framework\View\Layout->getBlock() called at [generated/code/Magento/Framework/View/Layout/Interceptor.php:414]\n#29 Magento\Framework\View\Layout\Interceptor->getBlock() called at [vendor/magento/module-backend/Model/View/Result/Page.php:26]\n#30 Magento\Backend\Model\View\Result\Page->setActiveMenu() called at [generated/code/Magento/Backend/Model/View/Result/Page/Interceptor.php:24]\n#31 Magento\Backend\Model\View\Result\Page\Interceptor->setActiveMenu() called at [vendor/magento/module-customer/Controller/Adminhtml/Index/Index.php:28]\n#32 Magento\Customer\Controller\Adminhtml\Index\Index->execute() called at [vendor/magento/framework/App/Action/Action.php:108]\n#33 Magento\Framework\App\Action\Action->dispatch() called at [vendor/magento/module-backend/App/AbstractAction.php:231]\n#34 Magento\Backend\App\AbstractAction->dispatch() called at [vendor/magento/framework/Interception/Interceptor.php:58]\n#35 Magento\Customer\Controller\Adminhtml\Index\Index\Interceptor->___callParent() called at [vendor/magento/framework/Interception/Interceptor.php:138]\n#36 Magento\Customer\Controller\Adminhtml\Index\Index\Interceptor->Magento\Framework\Interception\{closure}() called at [vendor/magento/module-backend/App/Action/Plugin/Authentication.php:143]\n#37 Magento\Backend\App\Action\Plugin\Authentication->aroundDispatch() called at [vendor/magento/framework/Interception/Interceptor.php:135]\n#38 Magento\Customer\Controller\Adminhtml\Index\Index\Interceptor->Magento\Framework\Interception\{closure}() called at [vendor/magento/framework/Interception/Interceptor.php:153]\n#39 Magento\Customer\Controller\Adminhtml\Index\Index\Interceptor->___callPlugins() called at [generated/code/Magento/Customer/Controller/Adminhtml/Index/Index/Interceptor.php:26]\n#40 Magento\Customer\Controller\Adminhtml\Index\Index\Interceptor->dispatch() called at [vendor/magento/framework/App/FrontController.php:159]\n#41 Magento\Framework\App\FrontController->processRequest() called at [vendor/magento/framework/App/FrontController.php:99]\n#42 Magento\Framework\App\FrontController->dispatch() called at [vendor/magento/framework/Interception/Interceptor.php:58]\n#43 Magento\Framework\App\FrontController\Interceptor->___callParent() called at [vendor/magento/framework/Interception/Interceptor.php:138]\n#44 Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}() called at [vendor/magento/framework/Interception/Interceptor.php:153]\n#45 Magento\Framework\App\FrontController\Interceptor->___callPlugins() called at [generated/code/Magento/Framework/App/FrontController/Interceptor.php:26]\n#46 Magento\Framework\App\FrontController\Interceptor->dispatch() called at [vendor/magento/framework/App/Http.php:137]\n#47 Magento\Framework\App\Http->launch() called at [generated/code/Magento/Framework/App/Http/Interceptor.php:24]\n#48 Magento\Framework\App\Http\Interceptor->launch() called at [vendor/magento/framework/App/Bootstrap.php:261]\n#49 Magento\Framework\App\Bootstrap->run() called at [index.php:39]\n</pre>","url":"/stadmin/customer/index/","script_name":"/index.php"}

  • Can you do reindex and set permissions correctly? – Sukumar Gorai Dec 31 '19 at 8:50
  • Find the rows that have "frontend_input" is "select" and "source_model" is "NULL" from "eav_attributes" table and check after change from "select" to "text". Please take before change anything in DB. – Kishor Thummar Dec 31 '19 at 10:52
  • I fixed the issue I edited customer_eav_attribute table and removed records, there were some records with wrong Attribute ID table should list in sequence but I found some records where showing like 1,2,3,4,5, 10,12,14,20 I just removed 10,12,14,20 and it worked fine ! if anyone have the same issue I strongly recommend you to take back of table first! – Zuby Dec 31 '19 at 13:41
1

I fixed the issue I edited customer_eav_attribute table and removed records, there were some records with wrong Attribute ID table should list in sequence but I found some records where showing like 1,2,3,4,5, 10,12,14,20 I just removed 10,12,14,20 and it worked fine ! if anyone have the same issue I strongly recommend you to take back of table first!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.