1

I am using magento2.2.6 cloud version and while updating ece-tools version and push changes to cloud environment it is displaying below error.

W: Package container-interop/container-interop is abandoned, you should avoid using it. Use psr/container instead.
W: Generating optimized autoload files
W: File doesn't exist: bin/docker
W: Check "chmod" section in composer.json of magento/ece-tools package.
Could not open input file: ./vendor/bin/ece-tools

However I tried to remove container-interop/container-interop package but still having same error.

I have already followed below documents provided by magento. https://devdocs.magento.com/cloud/project/ece-tools-upgrade-project.html#remove-deprecated-packages

https://devdocs.magento.com/cloud/project/ece-tools-update.html

Anyone have idea about this error?

0

Please try removing files from bin directory.

Running composer clear-cache && composer update afterward should add new binary files and solve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.