3

default,page_cache redis cache data doesnot set expiry it always set to -1 please suggest a way to add expiry time for redis keys

Due to this RAM is overflows regularly

'cache' => [
    'frontend' => [
        'default' => [
            'backend' => 'Cm_Cache_Backend_Redis',
            'backend_options' => [
                'server' => '127.0.0.1', 
                'database' => '2', //18
                'port' => '6379',

            ]
        ],
        'page_cache' => [
            'backend' => 'Cm_Cache_Backend_Redis',
            'backend_options' => [
                'server' => '127.0.0.1', 
                'port' => '6379',
                'database' => '3', //19
                'compress_data' => '0',

            ]
        ]
    ],

1 Answer 1

3

by using the options , we can set expiry date

            'auto_expire_lifetime' => '54321',
            'auto_expire_pattern' => '/^[a-zA-Z0-9._-]/',
            'lifetimelimit' => '555'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.