2

I am using magento 2.3 When I try placeorder. It doesn't have any mail. I use mail server. My mail sender: [email protected]

If I use SMPT module and change sender email to gmail then it works. So, I think it relate to some setting for mail server or I am missing some step. Anyone help me?

1 Answer 1

1

If you have properly configured Magento 2 mailing systems, you may need to check below point:

Got to Stores -> Configuration -> Advanced -> System Under Mail Sending Settings to make sure Disable Email Communications is set to No. Also, verify your Host and Port fields if you are using any external mailing server.

Got to Stores -> Configuration -> Sales -> Sales Emails Under the General Settings tab, choose Asynchronous sending to Disable

Under Order tab Enabled to Yes

Now clear/refresh your cache also check-in log file. Another way setup cron or not check below command

//cron setup

php -dmemory_limit=-1 bin/magento cron:install 

//cron run manually

php -dmemory_limit=-1 bin/magento cron:run

//cron list

crontab -l

please more refer to this hope working link also useful.

5
  • Vishal, I have same your setting. However, it effect with mail server like my email sender: [email protected]. If I use gmail then it sends mail normally
    – the light
    Commented Dec 30, 2019 at 3:45
  • Gmail is working because have already account exists but [email protected] email already create on the server ? Commented Dec 30, 2019 at 4:26
  • I have to fetch same issue like Gmail work but another ID not working so you need to check ID in particular server exits or not. Commented Dec 30, 2019 at 4:29
  • Yes, I have created account email on server. My account exist. So I dont sure about what the issues in here
    – the light
    Commented Dec 30, 2019 at 4:34
  • are you check this link magecomp.com/blog/… Commented Dec 30, 2019 at 4:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.