0

Has anyone from magento community upgraded the Braintree module to version 3.4.1 . i tried to install it through composer via the following command ,

composer require paypal/module-braintree:3.4.1 --no-update

but got the following error

[InvalidArgumentException]
Could not find a matching version of package paypal/module-braintree. Check the package spelling, your version constraint and
that the package is available in a stability which matches your minimum-stability (stable).

so i downloaded the module from the magento marketplace instead https://marketplace.magento.com/paypal-module-braintree.html

and placed the module to vendor/magento/module-braintree The module has been installed alright but when payment is made on frontend , it throws error Class League\ISO3166\ISO3166 does not exist

can anyone suggest how to proceed further ?

2
  • Any update on this? Have you been able to find a solution?
    – lisali
    Commented Oct 12, 2020 at 10:52
  • 1
    no , our magento version was 2.2 so it was not possible for us to even update the braintree module to the latest version as it was not compatible with 2.2 , this is what i believe . So i downgraded the module to a lower version . Commented Oct 12, 2020 at 12:08

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.