0

I know its a simple question, but I am getting an issue while disabling my Magento_Banner.

I followed this doc

https://devdocs.magento.com/guides/v2.3/config-guide/config/disable-module-output.html

But i am getting this error Table magento_banner do not have a column with name banner_id on running bin/magento setup:upgrade command.

enter image description here

on running bin/magento module:disable Magento_Banner

enter image description here

0

Things to Remember While Enabling or Disabling Magento 2 Extensions

Some modules(e.g Magento_Banner) have dependencies on other modules due to which, modules can be disabled or enabled. Here are some examples of it:

  • If Module A depends on module B, then you have to disable Module A first because you cannot disable Module B directly.
  • If Module A depends on module B, then you have to enable Module B first because you cannot enable Module A directly.
  • If Module A conflicts with Module B then you cannot enable Module A and Module B at the same time. However, you can disable Module A and Module B, or you can disable either module.

[Updated]

Disable module output in a simple deployment

The procedure for disabling module output on a single instance of Magento is easier because the changes don’t have to be distributed.

  1. Archive the original <Magento_install_dir>/vendor/magento/module-backend/etc/config.xml file.
  2. Add lines similar to the following to the <Magento_install_dir>/vendor/magento/module-backend/etc/config.xml file, directly under the <default> element:

    <default>
        <advanced>
            <modules_disable_output>
                <Magento_Banner>1</Magento_Banner>
            </modules_disable_output>
        </advanced>
        ............
    </default>
    

Run the following command to export the configuration changes:

$ bin/magento app:config:dump

The results are written to the /app/etc/config.php file.

Next, clear the cache to enable the new setting:

$ bin/magento cache:clean config

Go to admin->content->content. You can see Dynamic Block is disabled.

See the below link to get more in detail

Disable module output

| improve this answer | |
  • i already tried this, no success, – summu Dec 26 '19 at 6:52
  • Updated my answer. Check wheather you are doing the same. Becouse Its verified in M233. – Supravat Mondal Dec 26 '19 at 7:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.