0

It doesn't seem like the cron job is doing anything. I keep getting warnings in the admin panel that the indexes are invalid. The crontab file is as expected. The emails are not getting sent either.

#~ MAGENTO START 
* * * * * /opt/plesk/php/7.2/bin/php /var/www/vhosts/steamspeed.com/httpdocs/bin/magento cron:run 2>&1 | grep -v "Ran jobs by schedule" >> /var/www/vhosts/var/log/magento.cron.log
* * * * * /opt/plesk/php/7.2/bin/php /var/www/update/cron.php >> /var/www/httpdocs/var/log/update.cron.log
* * * * * /opt/plesk/php/7.2/bin/php /var/www/httpdocs/bin/magento setup:cron:run >> /var/www/httpdocs/var/log/setup.cron.log
* * * * * /opt/plesk/php/7.2/bin/php /var/www/httpdocs/bin/magento php indexer:reindex
#~ MAGENTO END 
* * * * * date >> ~/cron-test.txt

So, I added that cron-text.txt job, and it adds the date/time to that txt file.

~$ cat cron-test.txt
Tue Dec 24 01:30:01 UTC 2019

Currently, my crown config is set to defaults. Any suggestion why nothing seems to be happening?

default cron settings

1

May Issue on cron setup so let run the below command

//cron setup

php -dmemory_limit=-1 bin/magento cron:install

//cron run

php -dmemory_limit=-1 bin/magento cron:run

Also, check-in the log file may be permission issue more reference check link

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.