0

I was trying to add a new payment method klarna. I configured klarna in a proper way and I couldn't save it.

Further try to some other changes in stores->setting->configuration->sales->payement method But nothing gets saved.

It takes me to the top of the page. Can anyone say why it occurs like this and need a solution for it. thanks in advance.

1

In my case Firefox was auto-filling the "PayPal Express Checkout" configuration with Magento login credentials. Click "Configure" next to "PayPal Express Checkout" and remove the auto-filled credentials.

0

There may be two cause to not work save button.

  1. May be there is a required field, due to that save button is not working. So first check all accordion and make sure no required field is blank.
  2. Please check in console, may be due to some JS error, save button is not working.
  • If there is required field it takes scrolls down to the the place where the field is required and not to the top @Dj_Dev – Haerriz Dec 20 '19 at 14:02
  • I have checked it in console and I find nothing wrong in that. – Haerriz Dec 20 '19 at 14:03
0

I found the answer. I saw that Authorize.Net was turned on by default, but not configured.

So I turned off Authorize.Net and then made changes in the payement method and so the save config worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.