I set Magento up using Cloudways, and now I'm trying to move it to my local Ubuntu VM. I used the official

.gitignore from Magento

cloned the project locally, ran composer install, made sure that I had my env.php and config.php files downloaded and in the right place.

I changed the entire www directory and all its sub dirs to 777

I updated core_config_data url's to be the same as the one's I set in sites-available

I ran setup:upgrade





setup:static -content:deploy -f

I tried the above in any number of orders. I tried deleting and re-cloning the repo.

I sometimes get the white screen of death, and sometimes I see the folder structure, but with no styles applied.

I'm using the Porto theme, and had removed the child theme because it hadn't been set up properly.

Everything works on my live site, but not locally.

I have the most recent database on my local MySQL.

Any help would be appreciated. Thank you My logs are full of "broken reference" warnings

  • Check do you have app/.htaccess it's excluded in gitignore. When it's white screen read server error Apache logs for clues.
    – BartZalas
    Dec 19, 2019 at 21:25
  • I have it. <IfVersion < 2.4> order allow,deny deny from all </IfVersion> <IfVersion >= 2.4> Require all denied </IfVersion>
    – web master
    Dec 19, 2019 at 21:37
  • If style not applied then check once mode rewrite is working properly ?
    – user55548
    Dec 20, 2019 at 7:06
  • mod rewrite is enabled in apache.
    – web master
    Dec 20, 2019 at 13:30
  • Is it fine when you switch to developer mode?
    – BartZalas
    Dec 20, 2019 at 17:45

1 Answer 1


I had to do 2 things to get it to work:

1: I had to change core_config_data use_secure_adminhtml from 1 to 0 (local dev env, so no security issue), and I had to ease up the permissions so that the static content could generate.

Up and running now

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.