1

My current version of Magento is 2.3.2 . I followed the docs and i executed the following commands in the console:

cp composer.json composer.json.bak
composer remove magento/product-community-edition --no-update
composer require magento/product-community-edition=2.3.3 --no-updatecomposer require --dev allure-framework/allure-phpunit:~1.2.0 friendsofphp/php-cs-fixer:~2.14.0 lusitanian/oauth:~0.8.10 magento/magento-coding-standard:~3.0.0 magento/magento2-functional-testing-framework:2.4.5 pdepend/pdepend:2.5.2 phpmd/phpmd:@stable phpunit/phpunit:~6.5.0 sebastian/phpcpd:~3.0.0 squizlabs/php_codesniffer:~3.4.0 --sort-packages --no-update
composer remove --dev sjparkinson/static-review fabpot/php-cs-fixer --no-update

composer update

The result of the composer update is the following:

  [Composer\DependencyResolver\SolverProblemsException]                                                                                       
  Problem 1                                                                                                                                   
      - Installation request for magento/product-community-edition 2.3.3 -> satisfiable by magento/product-community-edition[2.3.3].          
      - magento/product-community-edition 2.3.3 requires guzzlehttp/guzzle ^6.3.3 -> no matching package found.                               
    Problem 2                                                                                                                                 
      - magento/framework 102.0.3 requires guzzlehttp/guzzle ^6.3.3 -> no matching package found.                                             
      - magento/module-wishlist-sample-data 100.3.3 requires magento/framework 102.0.* -> satisfiable by magento/framework[102.0.3].          
      - Installation request for magento/module-wishlist-sample-data 100.3.* -> satisfiable by magento/module-wishlist-sample-data[100.3.3].  

  Potential causes:                                                                                                                           
   - A typo in the package name                                                                                                               
   - The package is not available in a stable-enough version according to your minimum-stability setting                                      
     see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.                                                       
   - It's a private package and you forgot to add a custom repository to find it                                                              

  Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.   

Does anyone know how to fix the this guzzle issue ? Thnx!

1
  • Did you try my suggestion?
    – M. Sonah
    Commented Dec 18, 2019 at 23:08

2 Answers 2

0

Before starting, make sure you are running PHP 7.1 or 7.2 (recommended).

These are the commands I run:
composer require magento/product-community-edition=2.3.3 --no-update
composer require --dev phpunit/phpunit:~6.2.0 friendsofphp/php-cs-fixer:~2.10.1 lusitanian/oauth:~0.8.10 pdepend/pdepend:2.5.2 sebastian/phpcpd:~3.0.0 squizlabs/php_codesniffer:3.2.2 --no-update
composer remove --dev sjparkinson/static-review fabpot/php-cs-fixer --no-update

Add "Zend\\Mvc\\Controller\\": "setup/src/Zend/Mvc/Controller/" to "autoload": "psr-4" in composer.json if it's not there.

Then run composer:update and finish as normal.

Check the vendor folder for guzzlehttp. If that doesn't exist, I'd get a copy of it from the Magento 2 install archive.

2
  • I don't see how this addresses his missing Guzzle package issue
    – M. Sonah
    Commented Dec 14, 2019 at 0:11
  • hmmm I removed the guzzlehttp package from the vendor folder and the composer update was succesfull. I refreshed the magento page and i received this error message: Please upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory. So I run the command, but it seems to be stuck here Upgrading data... . I wait 3 hours and it still running :)) . Any ideas ? Commented Dec 14, 2019 at 12:09
0

In your Magento root dir, run this command to pull the guzzle package.

composer require guzzlehttp/guzzle

then go back to your Magento composer installation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.