0

Hi guys ive been trying to upgrade our magento 2 store from 2.2 to 2.3 but im getting some odd dependancy issues. Does anyone have any suggestions?

This is the error:

Problem 1
- Conclusion: don't install magento/product-community-edition 2.3.3
- magento/product-community-edition 2.3.3 requires magento/framework 102.0.3 -> satisfiable by magento/framework[102.0.3].
- Conclusion: don't install magento/framework 102.0.3
- Conclusion: don't install symfony/console v3.4.36
- Installation request for magento/product-community-edition 2.3.3 -> satisfiable by magento/product-community-edition[2.3.3].
- Conclusion: don't install symfony/console v2.8.38
- Conclusion: don't install symfony/console v4.1.1|install symfony/console v2.8.38
- Conclusion: don't install symfony/console v4.1.2|install symfony/console v2.8.38
- Conclusion: don't install symfony/console v4.1.3|install symfony/console v2.8.38
- Conclusion: don't install symfony/console v4.1.4|install symfony/console v2.8.38
- Conclusion: don't install symfony/console v4.1.5|install symfony/console v2.8.38
- Conclusion: don't install symfony/console v4.1.6|install symfony/console v2.8.38
- Conclusion: don't install symfony/console v4.1.7|install symfony/console v2.8.38
- Conclusion: don't install symfony/console v4.1.8|install symfony/console v2.8.38
- Conclusion: don't install symfony/console v4.1.9|install symfony/console v2.8.38
- Conclusion: don't install symfony/console v4.1.10|install symfony/console v2.8.38
- Conclusion: don't install symfony/console v4.1.11|install symfony/console v2.8.38
- Installation request for sebastian/phpcpd 2.0.4 -> satisfiable by sebastian/phpcpd[2.0.4].
- Can only install one of: symfony/console[v4.1.0, v3.4.21].
- Can only install one of: symfony/console[v4.1.0, v3.4.22].
- Can only install one of: symfony/console[v4.1.0, v3.4.23].
- Can only install one of: symfony/console[v4.1.0, v3.4.24].
- Can only install one of: symfony/console[v4.1.0, v3.4.25].
- Can only install one of: symfony/console[v4.1.0, v3.4.26].
- Can only install one of: symfony/console[v4.1.0, v3.4.27].
- Can only install one of: symfony/console[v4.1.0, v3.4.28].
- Can only install one of: symfony/console[v4.1.0, v3.4.29].
- Can only install one of: symfony/console[v4.1.0, v3.4.30].
- Can only install one of: symfony/console[v4.1.0, v3.4.31].
- Can only install one of: symfony/console[v4.1.0, v3.4.32].
- Can only install one of: symfony/console[v4.1.0, v3.4.33].
- Can only install one of: symfony/console[v4.1.0, v3.4.34].
- Can only install one of: symfony/console[v4.1.0, v3.4.35].
- magento/framework 102.0.3 requires symfony/console ~4.1.0 -> satisfiable by symfony/console[v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9].
- Conclusion: don't install symfony/console v4.1.12|install symfony/console v2.8.38
- Conclusion: don't install symfony/console v4.1.0|install symfony/console v2.8.38|install symfony/console v3.4.21|install symfony/console v3.4.22|install symfony/console v3.4.23|install symfony/console v3.4.24|install symfony/console v3.4.25|install symfony/console v3.4.26|install symfony/console v3.4.27|install symfony/console v3.4.28|install symfony/console v3.4.29|install symfony/console v3.4.30|install symfony/console v3.4.31|install symfony/console v3.4.32|install symfony/console v3.4.33|install symfony/console v3.4.34|install symfony/console v3.4.35|install symfony/console v3.4.36

If there is anything else you guys need to help let me know and ill get it as soon as possible!

1 Answer 1

0

Are you getting this error from admin wizard? or by composer updates command?

4
  • Getting errors from the admin wizzard Dec 12, 2019 at 11:34
  • My suggestion to upgrade it with composer, Just change the version of magento product in composer.json file and then run the command composer update using ssh, Once it successfull, Than run magento update and other command. Hope it will solve your issue
    – Jarnail
    Dec 12, 2019 at 11:42
  • Need to specify Magento packages, Specify additional packages and Remove unused packages. You can review magento.stackexchange.com/questions/99813/… . It's already answered. Dec 12, 2019 at 11:43
  • As far as im aware we have already removed any unused packages and as we are upgrading through the web wizard does that not also update the packages that I selected? Dec 12, 2019 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.