1

I am using mageplaza google recaptcha in login, create user,forgot pass an so, But while doing any operation the recaptcha load very slow, and user submits data before captcha reload. Hence user often get recaptcha invalid issue.

How may i load recptcha with page load.

I used

$(".action.captcha-reload").trigger("click");
jQuery( "captcha-button-selector" ).trigger( "click" );

I used this two solutions.But no help.

4

From Magento 2.3.x, no need to installed extension for Google ReCaptcha. Magento provides inbuilt functionality for Google ReCaptcha. Find Admin Settings to enable.

Admin Panel -> Stores -> Settings -> Configuration -> Security -> Google reCaptcha -> Make It Enable

Add Google API website key & Google API secret key in General Section.

| improve this answer | |
  • yes i did. But it showing ERROR for site owner: Invalid key type.. there is no recaaptcha type V3 setting in magento 2.3.2 – Maruti_magento2 Dec 11 '19 at 6:25
  • 1
    There are two types of Google ReCaptcha available. reCaptcha V2 and Invisible reCaptcha. – Vrajesh Patel Dec 11 '19 at 6:35
  • yes i have added invisible captcha.Now working fine in firefox. But chrome ,it takes to much time. Sometimes user fills the data and submit.Hence error comes. captach not found. – Maruti_magento2 Dec 11 '19 at 8:54
  • Can you please share error screen shot? – Vrajesh Patel Dec 11 '19 at 8:58
  • there is no error. Just that captcha is invisible – Maruti_magento2 Dec 11 '19 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.