1

I have tried to disable Magento_CatalogSearch in config.php.

After edited config.php, While trying to run commands throws the following error.

"Source class "\Magento\CatalogSearch\Model\ResourceModel\Fulltext\SearchCollection" for "Magento\CatalogSearch\Model\ResourceModel\Fulltext\SearchCollectionFactory" generation does not exist."

Can any one please resolve my problem

1
  • please remove once "var/generated/" autogenerated files for Magento and try to run a command again – Shailesh Katarmal Dec 9 '19 at 12:32
1

I have solved the problem as you said removed generated , But I forget to delete var/cache/*. After that, I have run di: compile command and works fine

1

Please run below command once

rm -rf generated/* var/view_preprocessed/* var/cache/* var/page_cache/*

Then try to run deployment commands, because if you will try to disable module using config.php file then some auto generated class still available in generated directory that creates this issue. So please try to remove that or you can rename generated directory. Also please check permission of var and generated directory once, it should be 777.

Hope this will help you!

5
  • I have renamed the generated folder and also removed var/view_preprocessed/* but still unable to clear cache – Jaisa Dec 9 '19 at 12:36
  • Still the error is throwing – Jaisa Dec 9 '19 at 12:36
  • Sorry I was forget to mention cache and page_cache directory here. @Jaisa – Kishan Savaliya Dec 9 '19 at 14:43
  • 1
    It's okay. @Kishan... Thanks for the timely help – Jaisa Dec 10 '19 at 4:55
  • You're welcome Buddy @Jaisa – Kishan Savaliya Dec 10 '19 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.