When I try to login as a customer it does nothing!

If I use a valid email address and password it reloads the page but doesn't log me in or display an error.

If I use an invalid email address and password it shows me the usual ‘account doesn't exist’ error message.

Anyone have any ideas?



The issue is raising because the custom login form does not contain any form_key and there is a form key validation happening in loginPostAction of magento.

Step 1 : Open template/customer/form/login.phtml and template/persistent/customer/form/login.phtml and under.

Step 2 : Add the Below Line in <ul class="form-list">.

<input type="hidden" name="form_key" value="<?php echo Mage::getSingleton('core/session')->getFormKey(); ?>" />

Step 3 : Refresh your Cache and Now test.

Enjoy :)

| improve this answer | |
  • Tried this, still doesn't work :( Thanks anyway though. – Scott Bowers Jul 23 '14 at 10:39
  • Then check the permission as @mbalparda said – Keyul Shah Jul 23 '14 at 11:22
  • I have, still hasn't fixed my issue unfortunately. – Scott Bowers Jul 23 '14 at 11:23
  • That means you have install some Extension so that problem will arise you have to find that module and solve that prb – Keyul Shah Jul 23 '14 at 11:47
  • I've disabled all extensions via their XML under app/etc/modules and it still doesn't work. Not sure what it could be because all my sessions within the admin panel work perfectly fine. – Scott Bowers Jul 23 '14 at 15:24

Try to log on using incognito / anonymous mode. Or wipe your browser session data. It happens now and then.

| improve this answer | |

Give read and write permissions to your sessions folder if you are using files and if it does not work change your session path to db. Check your cookie path after clearing them. Try to login in te admin and check the behavior there too.

| improve this answer | |
  • Tried the file permissions but still no luck. Would you be able to elaborate further on the session path to db please? Many thanks. – Scott Bowers Jul 23 '14 at 10:38
  • Open your ap/etc/local.xml file and change the <session_save><![CDATA[files]]></session_save> to <session_save><![CDATA[db]]></session_save> – mbalparda Jul 23 '14 at 10:40
  • Still no luck unfortunately :( Thank you anyway. – Scott Bowers Jul 23 '14 at 11:07
  • Did you get any solution ? i have similar issue. thanks – Shamim Ahmed Apr 12 '16 at 9:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.