2

I'm trying to update Magento EE 2.2.7 to version 2.3.3 using the command line:

I have tried using bellow command but getting errors

  • List item

Command :

composer update

Output:

    Problem 1
                - magento/framework 101.0.9 requires php ~7.0.13|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.18 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.8 requires php ~7.0.13|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.17 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.7 requires php ~7.0.13|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.16 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.6 requires php ~7.0.13|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.15 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.14 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.5 requires php ~7.0.13|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.4 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.13 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.3 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.12 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.2 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.11 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.10 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.1 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.0 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.0-rc30 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.0-rc23 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.0-rc22 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.0-rc21 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.1 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.0-rc3 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.0-rc2 requires php ~5.5.22|~5.6.0|~7.0.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 100.1.0-rc1 requires php ~5.5.22|~5.6.0|~7.0.0 -> your PHP version (7.2.25) does not satisfy that requirement.
                - magento/framework 101.0.7 requires ext-mcrypt * -> the requested PHP extension mcrypt is missing from your system.
                - snowdog/theme-blank-sass 1.100.4 requires magento/framework 100.1.*||101.0.* -> satisfiable by magento/framework[101.0.7, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 100.1.9, 101.0.0, 101.0.1, 100.1.10, 100.1.11, 101.0.2, 100.1.12, 101.0.3, 100.1.13, 101.0.4, 101.0.5, 100.1.14, 100.1.15, 101.0.6, 100.1.16, 100.1.17, 101.0.8, 100.1.18, 101.0.9, 101.0.10].
                - snowdog/theme-blank-sass 1.100.4 requires magento/framework 100.1.*||101.0.* -> satisfiable by magento/framework[101.0.7, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 101.0.0-rc21, 101.0.0-rc22, 101.0.0-rc23, 101.0.0-rc30, 100.1.9, 101.0.0, 101.0.1, 100.1.10, 100.1.11, 101.0.2, 100.1.12, 101.0.3, 100.1.13, 101.0.4, 101.0.5, 100.1.14, 100.1.15, 101.0.6, 100.1.16, 100.1.17, 101.0.8, 100.1.18, 101.0.9, 101.0.10].
                - magento/framework 101.0.10 requires zendframework/zend-stdlib ^2.7.7 -> satisfiable by zendframework/zend-stdlib[2.7.7].
                - Can only install one of: zendframework/zend-stdlib[3.2.1, 2.7.7].
                - Can only install one of: zendframework/zend-stdlib[3.2.1, 2.7.7].
                - magento/product-enterprise-edition 2.3.3 requires zendframework/zend-stdlib ^3.2.1 -> satisfiable by zendframework/zend-stdlib[3.2.1].
                - Installation request for magento/product-enterprise-edition 2.3.3 -> satisfiable by magento/product-enterprise-edition[2.3.3].
                - Installation request for snowdog/theme-blank-sass 1.100.4 -> satisfiable by snowdog/theme-blank-sass[1.100.4].

PHP version enter image description here if anyone has an idea help me..!

4
  • check in your config server file unix:/var/run/php/php7.0-fpm.sock; for nginx something like this for apache
    – xanka
    Dec 9, 2019 at 9:27
  • @xanka for apache what I do?
    – bharat
    Dec 9, 2019 at 9:39
  • check on your php.ini LoadModule php7_module modules/libphp7.so just sample
    – xanka
    Dec 9, 2019 at 10:01
  • This is maybe PHP version issue, you should try to down PHP version to PHP 7.0 Dec 10, 2019 at 4:36

4 Answers 4

1

Magento 2.3.1 is certified and tested on PHP 7.2.11. Magento 2.3.3 adds support for PHP 7.3.

May be php version issue. So try using php7.2.11 or php7.2.19 version.

0

Follow This Steps :-

Step 1:- sudo apt-get install -y php7.1 libapache2-mod-php7.1 php7.1-common php7.1-gd php7.1-mysql php7.1-curl php7.1-intl php7.1-xsl php7.1-mbstring php7.1-zip php7.1-bcmath php7.1-iconv php7.1-soap

Step 2 :- composer require magento/product-community-edition=2.3.3 --no-update

Step 3 :- composer require --dev allure-framework/allure-phpunit:~1.2.0 friendsofphp/php-cs-fixer:~2.13.0 lusitanian/oauth:~0.8.10
magento/magento-coding-standard:~1.0.0 magento/magento2-functional-testing-framework:~2.3.14 pdepend/pdepend:2.5.2 phpunit/phpunit:~6.5.0 sebastian/phpcpd:~3.0.0 squizlabs/php_codesniffer:3.3.1 --sort-packages --no-update

Step 4 :- composer remove --dev sjparkinson/static-review fabpot/php-cs-fixer --no-update

Step 5 :- Open composer.json and edit the "autoload": "psr-4" section to include "Zend\Mvc\Controller\": "setup/src/Zend/Mvc/Controller/":

Step 6 :- composer update

0

This is the Error of PHP Version, First Upgrade your PHP Version then run Upgradation Process.

PHP Version Compatiable with Magento 2.3.3 is -> ~7.1.3, ~7.2.0, ~7.3.0

Technology stack requirements

Complete all this Technology Stack Requirements then Upgrade Magento.

============================================
*Upgrade PHP version Command in Cent OS*

First Remove 
-----------------------
 yum remove -y php72w
 yum remove -y php72w*
 yum remove -y php72*

Then Install 
----------------------

rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

yum -y install php73w php73w-opcache
yum -y install php73w-fpm php73w-opcache
yum -y install yum-plugin-replace
yum replace php-common --replace-with=php73w-common

yum -y install php73w php73w-bcmath php73w-cli php73w-common php73w-dba php73w-devel php73w-embedded php73w-enchant php73w-fpm php73w-gd php73w-imap php73w-interbase php73w-intl php73w-ldap php73w-mbstring php73w-mcrypt php73w-mysql php73w-opcache php73w-pdo php73w-pdo_dblib php73w-pear php73w-pecl-apcu php73w-pecl-imagick php73w-pecl-memcached php73w-pecl-mongodb php73w-pecl-redis php73w-pecl-xdebug php73w-pgsql php73w-phpdbg php73w-process php73w-pspell php73w-recode php73w-snmp php73w-soap php73w-tidy php73w-xml php73w-xmlrpc

Restart server
-------------------------
 php -v
service httpd restart
service httpd status
service php-fpm status
service php-fpm start
service php-fpm status
service nginx status
iptables -F
setenforce=0
============================================
3
0

you have to use upgrade script:

https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/upgrade-with-script.html

Upgrading your Magento installation with our script, which makes the upgrade process semi-automated, is the preferred method.

php -f pre_composer_update_2.3.php -- --root='/path/to/magento' \
--repo='https://repo.magento.com/' \
--edition='enterprise' \
--version='2.3.3'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.