6

My Magento website is acting strangely.

Here is what happen this morning when I tried to log in to the backend this morning. I opened up the homepage and everything came up fine. I went to the backend and got the login page. After logging in though I am redirected to the Magento's Installation Wizard page. I clear my cache and sessions under /var and the process repeats. It happens randomly now. For example, if I go my about us page it works fine, but then I go to contact us and it goes to the installation page.

Any ideas anybody?

My site is not live. The last thing I remember doing was importing products using Magmi and I adding a web reference to a visual studio project.

Error logs are turning up no results because the redirect is not considered an error.

It seems like my local.xml is readable, but at some point, during usage of my site it becomes unreadable and requires the session and cache to be cleared.

Update:

I believe I found the error message that triggered this bug.

[Mon Jul 21 16:19:12 2014] [error] [client 10.0.0.115] PHP Warning: SoapServer::SoapServer(): I/O warning : failed to load external entity "http://hostname.com/index.php/api/soap/index/?wsdl=1&wsdl%2F_vti_bin%2FListData_svc%2F%24metadata=" in /var/www/html/lib/Zend/Soap/Server.php on line 811

What I forgot to mention before is that I ran into this bug a few weeks ago. However, the bug managed to fix itself so I thought nothing of it. But I checked the error log from last week when this bug appeared and this is the error.

[Wed Jul 09 13:41:40 2014] [error] [client 10.0.1.33] PHP Warning: SoapServer::SoapServer(): I/O warning : failed to load external entity "http://hostname.com/index.php/api/index/index/?wsdl=1" in /var/www/html/lib/Zend/Soap/Server.php on line 811

Maybe this will help.

Udate

Found this on the forums.

http://www.magentocommerce.com/boards/forum/viewthread/512408/

Problem with this is I don't have an old cache folders or sessions

  • Figure out why your local.xml is not readable, and the downloader shouldn't pop up anymore. – Vlad Preda Jul 22 '14 at 16:14
  • My local.xml is readable. I don't understand what the problem is! – Steven Lynn Jul 22 '14 at 17:11
  • How do you know local.xml is readable? – mbalparda Jul 22 '14 at 18:57
  • I checked it's permissions. It is set to 644. – Steven Lynn Jul 22 '14 at 19:12
  • 1
    Create a file test.php in your Magento web root, that contains <?php echo file_get_contents('app/etc/local.xml'). Open it from the browser. What do you see ? – Vlad Preda Jul 23 '14 at 10:10
7

We had this problem and now have both a cause and a solution.

The error behavior (redirecting to the Magento install wizard after a sucessful upgrade) is not random. It occurs when the SOAP API URL is hit. In our case we had a scheduled process that hit the SOAP API periodically. so it would occur, then go away then reoccur.

After time the behavior goes away. To make it happen... Load yourAPI URL in a browser http://hostname.com/api/soap/?wsdl The magento admin and likely the front end store pages will throw the 404/install.php page.

The cause of the issue was a PHP bug https://bugs.php.net/bug.php?id=62577 and Magento was able to provide a patch PATCH_SUPEE-3762_EE_1.14.0.1_v1.sh We were running Redhat 6 with PHP 5.3.3 (but this still occurs in PHP 5.3.28)

  • This should be the accepted answer since it solves the problem. It did for me. – frigg Jun 25 '15 at 8:31
  • @frigg this patch is for the enterprise edition. There is no patch for the community edition. That is why I didn't select this as the answer – Steven Lynn Jul 27 '15 at 20:06
  • As stated here, the patch is also for CE 1.9.x - I just used it on a CE 1.9.0.1 site. – Joseph Leedy Sep 25 '15 at 21:32
4

Alright this is the solution that fixed the problem I was having.

Step 1: Clear /var/cache and /var/session

Step 2: Reboot server

Step 3: Wonder why that just worked......

I plan on doing some more research on this problem.

Thanks to all that took the time to read and help.

Update

Here is the error that triggers the event.

[Thu Jul 24 08:20:40 2014] [error] [client 10.0.0.115] PHP Fatal error: SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://host.com/index.php/api/soap/index/?wsdl=1&wsdl%2F_vti_bin%2FListData_svc%2F%24metadata=' : failed to load external entity "http:// host.com/index.php/api/soap/index/?wsdl=1&wsdl%2F_vti_bin%2FListData_svc%2F%24metadata="\n in /var/www/html/lib/Zend/Soap/Server.php on line 811

[Thu Jul 24 08:20:46 2014] [error] [client 10.0.0.115] PHP Fatal error: SOAP-ERROR: Parsing WSDL: Couldn't find in 'http:// host/index.php/api/soap/index/?wsdl=1&wsdl%2Fmex=' in /var/www/html/lib/Zend/Soap/Server.php on line 811

Edit: 07-25-14

I got this error when adding a reference to a solution in visual studio.

I discovered that visual studio 2012 does not play well with soap v1. These following links ruin my site in visual studio, but work just fine in SOAPUI.

http://magentohost/api/?wsdl
http://magentohost/api/soap/?wsdl
  • 1
    This shouldn't be the accepted solution because it is too specific to your problem. Rebooting the server and clearing var is a temporary fix and does not solve the source of the problem. – Stevie G Feb 27 '15 at 12:19
1

Please check if your local.xml still exists.

  • yes the local.xml in app/etc still exist and looks to be unchanged. – Steven Lynn Jul 22 '14 at 13:29
1

There's something wrong in your front controller routing process.

The error message Front controller reached 100 router match iterations means the request for the page you called was not dispatched. Magento prevents running into an infinite loop by setting a counter while matching and checking for dispatched requests.

1

Debug your problem

First of all you should focus on the report. This is your core problem. It says that your routing is giving problems like Anna Völkl already said.
Here is a link to debug the problem better:
http://tutorialmagento.com/fixing-front-controller-reached-100-router-match-iterations
After this you should get debugging information in var/log/system.log.

Change Admin URL

Another thing you could try is change the admin URL in your local.xml. I had some issues in de past with wrong routing and this solved the problem for me. It's changing one word, doesn't hurt to try right? :-)

Search articles from people with same problem

My last tip is look around on Stackoverflow. You are not the first one with this problem. There are multiple similar posts which might help you. One of them: https://stackoverflow.com/questions/8929960/magento-cms-error-front-controller-reached-100-router-match-iterations

I hope this will help to get you closer to a solution. :-)

  • Debugging didn't turn up any results. I am no longer getting the 100 router match error. It isn't just the admin url that is redirected to install page. It happens randomly now. I have been searching for help all day. Thanks though (: – Steven Lynn Jul 22 '14 at 19:57
  • Hmm I'm sorry to hear that :(. Then I suggest to use a backup of the database to restore a previous (working) version or reinstall Magento if nothing else helps. – IJsbrand van Prattenburg Jul 22 '14 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.