0

I have tried all approaches from truncating to checking table alter permission under DB but the Product Flat Data indexing always say on Processing and required re-indexing anybody has any idea about to solve this.

2
  • Probably something crashed and the index process does not finish. Check the var/log folder for possible errors.
    – Marius
    Apr 13, 2013 at 8:03
  • Clear var/locks/* files & reindex via ssh
    – MagePsycho
    May 15, 2013 at 12:07

2 Answers 2

1

Errors with indexing are caught and not displayed if you re-index via the GUI.

If you re-index via command line, any errors will be displayed.

php shell/indexer.php --reindex ...

If you've got a large number of products/store views/attributes - then it will be slower to build. You should reall, test your store performance with it on and off, as it doesn't always provide a performance improvement.

1
  • 1
    Typo: Indexer.php -> indexer.php
    – MagePsycho
    May 15, 2013 at 12:05
0

I have this problem I created the file in the root and ran the following code and it worked

    <?php
set_time_limit(0);
error_reporting(0);
require_once './app/Mage.php';
umask(0);

$indexer="./shell/indexer.php";

if(file_exists($indexer))
{
                $idxlist=array("catalog_product_attribute",
                               "catalog_product_price",
                               "catalog_product_flat",
                               "catalog_category_flat",
                               "catalog_category_product",
                               "catalog_url",
                               "catalogsearch_fulltext",
                               "cataloginventory_stock");


        //reindex using magento command line
        foreach($idxlist as $idx)
        {
            echo "reindex $idx n ";
            exec("php shell/indexer.php --reindex $idx");
        }

}

Hope this will work for you too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.