1

I have created custom grid using UI component. My Full text searching showing error "Something went wrong with processing the default view and we have restored the filter to its original state.".

Below is my code:

<filterSearch name="fulltext">
            <argument name="data" xsi:type="array">
                <item name="config" xsi:type="array">
                    <item name="component" xsi:type="string">Magento_Ui/js/grid/search/search</item>
                    <item name="displayarea" xsi:type="string">dataGridFilters</item>
                    <item name="provider" xsi:type="string">affiliate_newlisting_listing.affiliate_newlisting_listing_data_source</item>
                    <item name="chipsProvider" xsi:type="string">affiliate_newlisting_listing.affiliate_newlisting_listing.listing_top.listing_filters_chips</item>
                    <item name="storageConfig" xsi:type="array">
                        <item name="provider" xsi:type="string">affiliate_newlisting_listing.affiliate_newlisting_listing.listing_top.bookmarks</item>
                        <item name="namespace" xsi:type="string">current.search</item>
                    </item>
                </item>
            </argument>
        </filterSearch>

what other things i have to do to make it working?

Thanks

  • 1
    I got the answer, I have gave Full Text Index in column in table and its working now. – Manish Soni Nov 28 '19 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.