3

I am trying to override the Paypal Standard Model using the following files:

app/code/local/Me/Paypal/etc/Config.xml

<?xml version="1.0"?>
<config>
    <modules>
        <me_paypal>
            <version>0.1</version>
        </me_paypal>
    </modules>
    <global>
       <models>
          <paypal>
              <rewrite>
                  <standard>Me_Paypal_Model_Standard</standard>
              </rewrite>
          </paypal>
       </models>
    </global>
</config>

app/code/local/Me/Paypal/Model/Standard.php

class Me_Paypal_Model_Standard extends Mage_Payment_Model_Method_Abstract{

        //my changed code here

}

The problem is that the changes I make to the Standard models code do not seem to be getting applied. Have I missed something?

3

Try
app/code/local/Me/Paypal/Model/Standard.php
instead of
app/code/local/Me/Paypal/Models/Standard.php

  • Sorry my bad, it is a typo on the question not the site itself. I have tried both "Model" and "model" neither work although I don't know the difference. – Matthew Dolman Jul 22 '14 at 4:56
  • Is your extension listed under System > Configuration > Advanced > Disable Modules Output? – Kristof at Fooman Jul 22 '14 at 4:58
  • It is listed as enabled – Matthew Dolman Jul 22 '14 at 5:00
  • is Config.xml just capitalised in the question? it should be lower case config.xml – Kristof at Fooman Jul 22 '14 at 5:05
  • super thanks. I can never get my head around the capitalization rules in magento modules – Matthew Dolman Jul 22 '14 at 5:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.