1

In my M 2.2.6 I can not enter the Category section of dashboard, the spining is turn around.

When I check the console, some of JS has 404 error

In - adminhtml/web/js/components/use-parent-settings -

select.js
single-checkbox.js
textarea.js
toggle-disabled-mixin.js

I add it manual via SFTP then run

bin/magento setup:static-content:deploy -f

Problem temporarily resolved, but after one day, I can not enter the category section on dashboard again. and again.

On the other hand I can not set to production to run

 bin/magento deploy:mode:set production

It gives an error like

The directory "/srv/public_html/pub/static/adminhtml/Magento/backend/tr_TR/Magento_Catalog/js/components/use-parent-settings/toggle-disabled-mixin.js" cannot be deleted Warning!rmdir(/srv/public_html/pub/static/adminhtml/Magento/backend/tr_TR/Magento_Catalog/js/components/use-parent-settings/toggle-disabled-mixin.js): Not a directory

As it appears that the symlinks are part of your deployment system, will need to fix the links to point to the appropriate place/file but I can not handle.

Any Suggestions?

1

Try to run command in this sequence

php bin/magento deploy:mode:set developer
php bin/magento deploy:mode:set production --skip-compilation
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento cache:clean
php bin/magento cache:flush
php bin/magento setup:static-content:deploy -f en_GB tr_TR

After running this commands you'll not get any issues then.

Hope this will work for you!

9
  • 1
    Yes it is working Thank you but now I can not switch to developer mode . It gives same error.. I can not reach any section on admin Dashboard ---- a4yewu6o72si64b8.mojostratus.io/static/version1574590607/… net::ERR_ABORTED 404 --- – ozan yeni Nov 24 '19 at 10:20
  • @ozanyeni, I can see this file is available on that path can you please open that URL once ? – Kishan Savaliya Nov 24 '19 at 10:38
  • 1
    Please run this command once php bin/magento setup:static-content:deploy -f en_GB tr_TR, and then check once. – Kishan Savaliya Nov 24 '19 at 10:53
  • Yes I solved Thank you. But I can not switch to developer :) – ozan yeni Nov 24 '19 at 11:10
  • 1
    There may be permission issue. Can you please run this sudo chmod -R 777 var/ pub/ generated/ – Kishan Savaliya Nov 24 '19 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.