I've moved my Magento 2.3.2 website from Shared Hosting where I developed it to a VPS. Everything on the Shared Hosting was working fine on checkout but right now, when a customer login and tries to Checkout this error message appears:

 Validate class not found from basename

I've tried and followed this: the Same issue reported.

With what is suggested adding include_path "." to my php.ini file, the result is, the error message no longer is showing but the delivery methods are not showing.

As it looks it feels like this stops the validation process for the address of the customer. Has anyone found a fix for this?

Edit: I am not using Plesk.


You can add this in your php.ini file

include_path = ".:/yourpathtomagento/vendor/magento/zendframework1/library"

Add your Magento Root directory path where I have mentioned yourpathtomagento in the above path and then check.

  • Note: Go to your console and move into your Magento installation directory and then run PWD command there and copy the whole path and paste there instead of this text yourpathtomagento.

Hope this will help you!

  • 1
    Thank you, your solution fixed the issue. – h3k Nov 21 '19 at 12:08
  • You're welcome buddy :) – Kishan Savaliya Nov 21 '19 at 12:08
  • How can i add this path in htaccess – Vinit Kumar Feb 3 '20 at 9:53
  • Vinit, php.ini not htaccess – LoudHouse Family Apr 5 '20 at 21:26

I have tried to follow your suggestions but in my directories i don'have zendframework1/library. I have zendframework and in this directory, other directories zend-* Do you know why i don't have zendframework1 or if i must choose one of directory under zendframework? Magento version 2.3.1 php 7.2 We use plesk


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.