1

I upgraded my site from Magento 1.7 to 1.8 but the onepage checkout is not working.I can never go to shipping method step.the continue button does nothing. I tried by modifying info.phtml and payment.phtml but no success. I have gone through the previous answers of same question and i tried everything. So THIS IS NOT A DUPLICATE QUESTION.

closed as too broad by mbalparda, Marius, davidalger, Fabian Blechschmidt, Keyul Shah Jul 22 '14 at 3:19

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • are you sure this not a form key issue? – MTM Jul 21 '14 at 18:32
  • @MTM Yes i checked the info.phtml file. and the review object is as follow: review = new Review('<?php echo $this->getUrl('checkout/onepage/saveOrder', array('form_key' => Mage::getSingleton('core/session')->getFormKey())) ?>', '<?php echo $this->getUrl('checkout/onepage/success') ?>', $('checkout-agreements')); Is there any other file to check? – Vishal Jul 21 '14 at 18:37
  • any clues in log file? – MTM Jul 21 '14 at 18:38
  • @MTM:Nope no clues. I observed the requests and came to know that the GET request after POST/SaveBilling is not fetched. – Vishal Jul 21 '14 at 18:42
  • @MTM : so the last request is POST which should be GET i think. – Vishal Jul 21 '14 at 18:43
2

Please check the file app/design/frontend/your package/ your theme / template/checkout/onepage/shipping_method.phtml and check if the id checkout-shipping-method-load exists. if not, please update the file with the new version. Additionally you may also check all the checkout related files if their codes are updated.

  • I found the solution. Everything was correct. But i had one extension that was overriding shipping method .I disabled the extension and it works. – Vishal Jul 22 '14 at 14:24
  • you can live with that module if its really required, as you know the reason of not working now. – MTM Jul 22 '14 at 18:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.