1

I've got a store which has had a significant upgrade.

Gone from 2.2.3 to 2.2.10. I've handled a lot of issues already. The frontend seems fine.

Having a problem with backend. Getting errors when loading admin grids. So just by logging in see errors like this:

Class argument is invalid: Magento\AdminNotification\Ui\Component\DataProvider\DataProvider

So I disable admin notifications via composer / CLI.

Then see similar error Magento\ReleaseNotification

So I disable release notifications via composer / CLI.

Can log in (or bypass dashboard) but then going to Catalog > Products for example

Class argument is invalid: Magento\Catalog\UI\DataProvider\Product\ProductDataProvider

So just generally seems to be an issue with admin grids

I've Googled and read about changes in XML syntax but surely I can't have an issue with all the core modules?

Has anyone experienced the same issue? Or can you point me in the right direction?

0

It was an issue specifically on dev install. Deployment to staging and live went fine.

In summary I think I had a mixture of old and new files - although something outside of vendor folder. So scaffolding for the framework.

I can't say exactly what went wrong. I hope this helps someone.

0

This issue arises when the magento core files are corrupted or when the installation is not done properly.

You can try few things like :

  • Reinstall the magento or
  • Take the working code of /vendor directory and replace it to target directory.
2
  • It was outside of composer. But I agree a broken install. – Dominic Xigen Jan 30 '20 at 13:02
  • Yes, I guess that might not be the solution using composer update, so updating the answer. – Sanjay Chaudhary Jan 30 '20 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.