1

I did some changes in js file of a third party extension. The path shown on frontend is

/pub/static/version1574138983/frontend/Smartwave/porto/en_US/Mageplaza_LayeredNavigation/js/view/layer.min.js

I did changes in

app/code/Mageplaza/LayeredNavigation/view/frontend/web/js/view/layer.js

This is the only file i think is responsible. Any changes done in this file is not getting reflected on frontend. I had run static-content deploy command also,but still did not work.

| improve this question | | | | |
  • have you checked pub/static folder? Is there available whatever changes you made? – Naresh Rupareliya Nov 19 '19 at 5:15
1

There is an error in your file layer.js

I will Explain why this Happen because you have enable the minify of JS.

Once you have enable the Minify JS. your JS file create min file then this name converts in .min.js & minify file creates in pub/static Path then now:

Your file path: app/code/Mageplaza/LayeredNavigation/view/frontend/web/js/view/layer.js

saved by Magento Path: /pub/static/version1574138983/frontend/Smartwave/porto/en_US/Mageplaza_LayeredNavigation/js/view/layer.min.js

Command to Execute after Changes are:

php bin/magento s:up && php bin/magento s:d:c && php bin/magento s:s:d -f && php bin/magento c:c && php bin/magento c:f && chmod -R 777 var/ pub/ generated/

Hope you understand!!

| improve this answer | | | | |
1

Try following way...

  1. Enable developer mode: php bin/magento deploy:mode:set developer.
  2. First change in js app/code/Mageplaza/LayeredNavigation/view/frontend/web/js/view/layer.js
  3. Clean pub/static/frontend directory.
  4. Run php bin/magento dev:source-theme:deploy -f
  5. Clean cache and also browser cache .
| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.