We've been trying to migrate our current M1.9.4.0 to M2.3.3 but we ran into an exception we can't seem to solve/ get rid of. This occurs wherever we go on the website; we cannot access the storefront or admin. The errors says:

Exception #0 (ReflectionException): Class Magento\Captcha\Model\Recaptcha does not exist

The full message: https://pastebin.com/nGqMtnKJ

We tried all the solutions we could find and already posted on the official Magento forum but so far the suggested solutions did not have any effect. For reference: https://community.magento.com/t5/Magento-2-x-Programming/Migration-M1-to-M2-but-ReflectionException-Class-Magento-Captcha/td-p/325657

Anyone got an idea what might cause this? Thank you!

  • Can you please confirm vendor/magento/module-captcha this directory available or not in your vendor ? Nov 15, 2019 at 15:56
  • The folder module-captcha in vendor/magento does exist.
    – Jess
    Nov 18, 2019 at 12:43
  • Please check my answer and let me know if it helps! Thanks Nov 18, 2019 at 12:46
  • Recapcha is not available in magento, you have to set it up.
    – user81967
    Nov 20, 2019 at 2:20

2 Answers 2


run di compile

*php bin/magento setup:di:compile*

It displayed there is syntax error and showed line number if any. Then updgrade,

*php bin/magento setup:upgrade*

and deploy,

*php bin/magento setup:static-content:deploy*

for developer mode,

*php bin/magento setup:static-content:deploy -f*

May be helpful.

  • Thank you. I ran these commands and it didn't return any warnings or errors whatsoever and executed perfectly. Problem still persists
    – Jess
    Nov 15, 2019 at 12:00

Try to run below command in your CLI

composer update
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy -f
php bin/magento cache:clean
php bin/magento cache:flush

Hope this will help you!

  • You got any solution here ? Dec 9, 2019 at 7:00
  • No, we tried all solutions and more but nothing worked. We ended up going with another migration tool and it pretty much worked flawlessly.
    – Jess
    Dec 12, 2019 at 9:29
  • @jxsh, Okay that's Great! :) Dec 12, 2019 at 9:30
  • Thank you for your time and help though :)
    – Jess
    Dec 12, 2019 at 9:37
  • You're always welcome Buddy ;) Dec 12, 2019 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.