0

I'm moving my site from cloudways to local. I used git to push everything to github, cloned it locally, brought the files into xampp, ran composer install, changed the urls in core_config_data to use localhost, and tried to open the site. I change the line in validator.php to make the slashes work on Windows.

When I look at the site, a huge mess comes up. When I look at my css urls, they all have a version thrown in

for example: http://localhost/pub/static/version1573762626/frontend/Smartwave/porto_child/en_US/icon-fonts/css/porto-icons-codes.css

How can I make this work?

I'm including my .gitignore file to see if I'm not pushing enough


# Metadata
/.buildpath
/.cache
/.metadata
/.project
/.settings
atlassian*
/nbproject
/sitemap
/.idea
/.gitattributes

# Magento specific configuration
/app/.htaccess
/app/bootstrap.php
/app/autoload.php
/app/functions.php
/app/etc/di.xml
/app/etc/vendor_path.php
/app/etc/NonComposerComponentRegistration.php

# Files re-generated through composer
/CHANGELOG.md
/CONTRIBUTING.md
/COPYING.txt
/ISSUE_TEMPLATE.md
/LICENSE_AFL.txt
/LICENSE.txt
/Gruntfile.js.sample
/nginx.conf.sample
/package.json.sample
/php.ini.sample
/vendor/*
/bin/*
/dev/*
/lib/*
/pub/*
/setup/*
/var/*

# Excludes (or a better alternative might be to symlink this to shared folders
!/pub/media/catalog
!/pub/media/porto
!/pub/media/downloadable
!/var/composer_home

Thanks

0

The version in the URL gets added with the feature "Static Content Signing" https://devdocs.magento.com/guides/v2.3/config-guide/cache/static-content-signing.html#static-content-signing

Try to disable the "Static Content Signing" from Admin > Store > Configuration > Advance > Developer > Static File settings as in the screen shot below:

enter image description here

Also, you can try to do generate the static content using the command bin/magento setup:static-content:deploy -f (where -f is to forcefully do the static-content deploy if you are in developer mode) using shell from your XAMPP and navigating to root directory of your project enter image description here

After, above command run bin/magento cache:clean

I hope that should help fix your issue.

1
  • I didn't fix the issue. I realized that when I go to /admin, even though I changed the secure and unsecure URLs in core_config_data to localhost, /admin redirects to the online version
    – web master
    Nov 15 '19 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.