1

I am trying to get my PayPal integration working but I have a problem. When I try to purchase anything using Website Payments Pro or Express Checkout, I get the following error.

PayPal gateway has rejected request. Timeout processing request (#10001: Internal Error).

When I first tried it with the live site it worked with Express Checkout but now it won't work.

Additional Info

Magento version: 1.7

template:Blanco

  • CLoudflare was the cause of the problem for me aswell. Cheers – Gazm Nov 9 '15 at 22:04
3

I had this problem. Can't explain it, but it was solved by simply removing the paypal credentials and disabling the solution. Then entering the credentials again and enabling.

Worked fine again after that.

3

Sounds like you are using live API credentials against the sandbox or vice versa. If it is the prior and you want to test against sandbox, go to the "Sandbox test accounts" page on Paypal. Select the account beginning with "paypal-facilitator@" and click "Profile". Set a password and make sure the account type is "Business-Pro". Go back to Magento and update the settings to use the "paypal-facilitator@" email and click the "Sandbox Credentials" button to generate the API credentials for Sandbox.

Sandbox test accounts:

https://developer.paypal.com/webapps/developer/applications/accounts

  • So that mean need use Sandboxed account not real one for magenot sandbox config – user956584 Feb 11 '15 at 13:30
  • 1
    Correct. You have to use different API credentials for sandbox. – Daniel Smith Feb 12 '15 at 20:01
0

Switch the CloudFlare off if you're using it, this what caused problem in my case.

0

Pause or deactivate the cloudfare.And check that bymistake not use space in paypal credential.No for sandbox if you don't use that credential.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.