1

I have installed magento 2 using composer by follow this commands:- https://www.simicart.com/blog/magento-2-composer/

My magento set up done without any error but with this set up, my new installed magento front end is working but admin link not working.

Can anyone please help me with this? I have tried by clear cache and removed folder of var and pub/static but still same.

Sorry might be my questions will be silly, i am in learning phase so hope you guys can understand.

Thanks

3
  • 1
    can you please try to access your backend with index.php ? like www.example.com/index.php/admin Nov 13, 2019 at 5:47
  • could you solve the issue?
    – Khushbu
    Nov 13, 2019 at 9:02
  • No, i have added index.php but that is not working.
    – Soni5041
    Nov 14, 2019 at 6:03

2 Answers 2

1

I was got same issue in my window local computer and i was solved by this way.

Remove everything, except .htaccess file from pub/static folder.

Open app/etc/di.xml file and find in

Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink

and replace to

Magento\Framework\App\View\Asset\MaterializationStrategy\Copy

Now execute bellow commands.

php bin/magento setup:upgrade; php bin/magento setup:static-content:deploy -f; php bin/magento setup:di:compile; php bin/magento cache:flush; sudo chmod -R 777 var pub generated;

3
  • Not working above solution.
    – Soni5041
    Nov 14, 2019 at 6:10
  • Are you using windows or ubuntu?
    – S.P
    Nov 14, 2019 at 6:40
  • Mint Linux system, Thanks for your response, i will try from magento docs once again and if then also wont work, will let you know.
    – Soni5041
    Nov 15, 2019 at 8:58
1

I have installed it again and now this time, i have not included this option in command "--backend-frontname="admin"".

as i have checked dev docs installation link and in that the above option not there so i removed and try again.

And its working now with auto generated admin url.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.