I have a problem with intergration of Paypal Plus Modul for Magento 2. I found this module on github


There are instructions not to install it on Magento 2 but I got stuck at the point with Run the command composer require iways/module-pay-pal-plus from instructions. I get in my SSH Console:

Could not find a matching version of package iways/module-pay-pal-plus.
Check the package spelling, your version constraint and that the package is available in a stability which matches your minimum-stability (stable).

I write in composer.json:

"repositories": {
"0": {
"type": "composer",
"url": "https://repo.magento.com/"
"1": {
"url": "[email protected]:i-ways/magento2-paypal-plus.git",
"type": "git"
"swissuplabs": {
"type": "composer",
"url": "https://ci.swissuplabs.com/api/packages.json"

please help, what's the problem?

1 Answer 1


Following the install instructions at the PayPal Plus extension repository on GitHub install the plugin as follows:

  1. Make sure that there are no code snippets from previous installation attempts in your composer.json.
  2. Add the extensions repository to the end of your composer.json:
    "repositories": [
                "url": "[email protected]:i-ways/magento2-paypal-plus.git",
                "type": "git"
  1. Save the changes to your composer.json file.
  2. To install the extension via composer, execute the command
    composer require iways/module-pay-pal-plus from the command line.
    (Alternatively you can install the extension by adding the following line to your composer.json: "require": { "iways/module-pay-pal-plus": "~1.0" })
    I recommend the method from 4. because it is not as error prone as editing the composer.json file by hand.
  3. After the extension is installed you can now activate it via the command line. To do so, go to the root directory of your Magento 2 instance and execute the following command:
    bin/magento module:enable --clear-static-content Iways_PayPalPlus
  4. To initialize the Database updates you must run following command afterwards:
    bin/magento setup:upgrade
  5. Static files may have to be generated and/or renewed. Execute this command:
    bin/magento setup:di:compile

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.