1

I am on Magento 2.3.2. I would like to install the new security patch so I ran-

composer require magento/product-enterprise-edition=2.3.2-p2 which gives me this output- 

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Can only install one of: magento/page-builder-commerce[1.0.3, 1.0.1].
- Can only install one of: magento/page-builder-commerce[1.0.3, 1.0.1].
- Can only install one of: magento/page-builder-commerce[1.0.1, 1.0.3].
- magento/product-enterprise-edition 2.3.2-p2 requires magento/page-builder-commerce 1.0.3 -> satisfiable by magento/page-builder-commerce[1.0.3].
- Installation request for magento/product-enterprise-edition 2.3.2-p2 -> satisfiable by magento/product-enterprise-edition[2.3.2-p2].
- Installation request for magento/page-builder-commerce (locked at 1.0.1) -> satisfiable by magento/page-builder-commerce[1.0.1].

I figured I would try and update pagebuilder.

composer update magento/module-page-builder
Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update

I tried adding the version number but that adds more errors-

composer require magento/module-page-builder:1.1.0
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
- magento/module-banner-page-builder 1.0.1 requires magento/module-page-builder 1.0.* -> satisfiable by magento/module-page-builder[1.0.1, 1.0.0, 1.0.3] but these conflict with your requirements or minimum-stability.
- magento/module-banner-page-builder 1.0.1 requires magento/module-page-builder 1.0.* -> satisfiable by magento/module-page-builder[1.0.1, 1.0.0, 1.0.3] but these conflict with your requirements or minimum-stability.
- magento/module-banner-page-builder 1.0.1 requires magento/module-page-builder 1.0.* -> satisfiable by magento/module-page-builder[1.0.1, 1.0.0, 1.0.3] but these conflict with your requirements or minimum-stability.
- Installation request for magento/module-banner-page-builder (locked at 1.0.1) -> satisfiable by magento/module-banner-page-builder[1.0.1].


Installation failed, reverting ./composer.json to its original content.

How can I install the security patch?

3 Answers 3

1
composer require magento/product-community-edition:2.3.2-p2 --no-update
composer require tig/postnl-magento2 --no-update
composer update

Is the response I got back from Magento support and it works.I have no idea what postnl is or why it would be required but this solved the issue.

0

Looks like tig/postnl-magento2 is required by magento/page-builder-commerce. Without the update below, I was not able to upgrade to 2.3.4 from 2.3.2-p2.

composer update magento/page-builder-commerce                           
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 4 installs, 0 updates, 0 removals
  - Installing setasign/fpdi (v2.3.2): Downloading (100%)         
  - Installing setasign/fpdf (1.8.2): Downloading (100%)         
  - Installing setasign/fpdi-fpdf (v2.2.0): Downloading (100%)         
  - Installing tig/postnl-magento2 (1.9.1.1): Downloading (100%) 
0

I had similar issue when updating from 2.3.3 to 2.3.3.p1. Solution provided by tjjen worked for me.

composer require magento/product-enterprise-edition:2.3.3-p1 --no-update
composer require tig/postnl-magento2 --no-update
composer update

But the module TIG_PostNL was installed and it broke a lot of functionality on the site.

The proper solution we found - using --with-dependencies param:

composer require magento/product-enterprise-edition:2.3.3-p1 --no-update
composer update magento/product-enterprise-edition --with-dependencies

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.