1

Magento ver. 2.3.3

Choose a few allowed countries.

Then go to Customer Address Edit Form in Admin area.

Country dropdown is not as we expected.

If I just use 1 country none will show up if you chose more then it will just take countries from the top.

Anyone had this issue ad anyone solve it?

1

Please open the below path file.

vendor/magento/module-customer/view/adminhtml/ui_component

open customer_address_form.xml and remove below code from line number.194

             <formElements>
                <select>
                    <settings>
                        <options class="Magento\Directory\Model\ResourceModel\Country\Collection"/>
                    </settings>
                </select>
            </formElements>

Remove the above code from the file and move this file to a local folder like below.

 app/code/Magento/Customer/view/adminhtml/ui_component/customer_address_form.xml

After remove that you will see your selected country into customer address edit in M2.

1
  • It works, but I cannot do it by override in custom module. – krybbio Dec 6 '19 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.