0

I have Magento 2 setup of version 2.2.2.

I have set the cronjobs as per guidelines.

When I check the cron_schedule table I can see multiple duplicate cronjobs entries. created_at is the same for the same job_code and scheduled_at time is set with a difference of 1 minute as per the below image.

enter image description here

I haven't changed any default configurations in configuration -> Advance -> System -> Cron (Scheduled Tasks).

  • I think you set 1-minute interval cron. Right? – Dhaduk Mitesh Nov 7 at 12:50
  • you are talking in crontab? – Rizwan Khan Nov 7 at 12:58
  • Yes @RizwanKhan – Dhaduk Mitesh Nov 7 at 12:59
  • Yes it is 1 miniute interval cron [* * * * *] – Rizwan Khan Nov 7 at 13:07
  • That's why scheduled_at time is set with a difference of 1 minutes. – Dhaduk Mitesh Nov 7 at 13:08
1

Go to configuration -> Advance -> System -> Cron (Scheduled Tasks) -> Cron configuration options for group: default.

Set Schedule Ahead for field as 1.

Please see the below screenshot.

enter image description here

And then check it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.