I am wondering if anyone can help.

I have made some design changes to the following category: https://www.valvesonline.co.uk/manual-valves/ball-valves.html

However these changes do not appear on the front end. The category title and description should be in the left hand column and the top image shouldn't even be showing. I am using layout update XML to make the changes and know it works, as I have made the changes to all other categories and they work fine.

I have cleared the cache, disabled and re-enabled the category and double checked but it isn't working.

Any advice would be appreciated.

Many thanks

  • 1
    have you checked if default store is selected ?? Commented Nov 6, 2019 at 4:41
  • Great suggestion, I actually just selected the store it was part of and noticed that category wasn't pulling the default settings through and got it fixed. Thank you! Commented Nov 6, 2019 at 8:27
  • Great!! You can answer your own question so that it may help other people as well Commented Nov 6, 2019 at 8:47

3 Answers 3


We have this one figured out.

On the categories admin page, I changed the Store View from All Store Views to the store in question, selected the category with the problem and noticed that the category settings were not selected to use default value.

Selecting the options to use default value works.

Hope this might help anyone experiencing a similar problem, just double check on the store view.

  • "Hope this might help anyone experiencing a similar problem, just double check on the store view." - it sure just helped me! Thanks for posting your solution. We had a few set up by different team members who may or may not have started by changing the scope. Commented Jul 28, 2023 at 15:35

After all the above process if it doesn't work go to system-> cache management->flush static Cache files don't freak out if interface changes, just do the same system-> cache management->flush static Cache files. interface will be back. Reload crtl+F5 on the browser and the changes will be visible. This process worked for me.


If someone is still struggling after applying all the answers above. Check if flat table for categories is enabled. If yes, you need to re-index "catalog_category_flat" after clearing the cache.

Flat table configuration is located under: Shops -> Configuration -> Catalog -> Catalog

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.