1

I'm facing an issue with the specific product visibility on the Magento 2.2.9 website. The configurable product is not visible to the assigned category or search page but accessible with its URL.

When I manually saved the product from the admin then the product is displaying on the category page but after indexing the product has gone from the category and search page.

I've checked all the below possibilities causing this issue but didn't get any luck.

  • Status must be Enabled (under General tab)
  • Visibility should be Catalog OR Catalog, Search (under General tab)
  • Stock Qty (quantity) of the associated products (under Inventory tab)
  • Stock Availability must be IN STOCK
  • The category should be assigned (under the Categories tab)
  • The website must be assigned (I'm using the single store mode)

Any help will be appreciated.

1

I run into a similar problem in our system. We saw no products in search results and the categories if

  • custom skin was applied and
  • elastic search was active

If we remove one condition, all works fine in our system. So if you use custom design and you can activate Luma in a test-system, you should try it.

Mario

  • Thank you for your answer. Can you please explain about custom skin was applied to the website? Does it mean custom theme? – Sumit Nov 6 at 10:08
  • 1
    We used the commercial Orson theme. After the activation of elastic search we missed all products in our categories and search results. We had some other issues with this theme. So we use a test system to reproduce it. In this test system, we could easily remove the theme, and all problems with search results were gone. – Mario Nov 6 at 10:14
  • OK, thank you for the information, I'll try it and let you know if works. +1 for the answer. :) – Sumit Nov 6 at 10:32
  • I've tried it and this is the root cause of the issue. Thank you. However, I'm searching for the fix without disabling the elastic search and custom theme on the website. If you've already done it then please let me know. – Sumit Nov 7 at 7:06
  • I'm sorry. But we found no solution. And the manufacturer of the theme ignores the support request. So we found no solution :-( – Mario Nov 7 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.