0

i have upgrade my magento version from 2.2.8 to 2.3.3 after upgrade when i run setup upgrade command i am getting this error in ebizmart mail chimp extension

Uncaught Error: Call to undefined method Ebizmarts\MailChimp\Helper\Data::encrypt()

Any help will be appreciated.

0

Delete your Ebizmart module for now, after upgrade again install this Module with upgraded libraries.

Process to Install are : (with composer)

  1. Run this command on Magento's root dir:

    composer config repositories.ebizmarts composer https://packages.ebizmarts.com

  2. Run this command on Magento's root dir. Contact us to get your access token.

    composer config http-basic.gitlab.ebizmarts.com token your_token

  3. Run this command to get the module.

    composer require ebizmarts/mailChimp

  4. Run this command to install the module bin/magento setup:upgrade

Hope this will help you!!

|improve this answer|||||
  • How to set theme after migration? – zus Nov 14 '19 at 6:46
  • no need to set theme, you need to basic integrate in magento2 to no sample data instance. – Oscprofessionals Nov 15 '19 at 5:47
0

The repos in https://packages.ebizmarts.com are private and you can't access if you don't have an user/pass (and you must pay for that)

As you know, mc-magento2 is a free extension and you can install it simply with composer (with no other unnecessary trick), and mc-magento2 is not in these repos!!

The problem here is, the version of mc-magento2 for magento 2.2.8 don't work in magento 2.3.3, so you must follow these steps

  1. Prior to update your magento, uninstall mc-magento2 (run composer remove mailchimp/mc-magento2)
  2. Once the extension is uninstalled, update your magento installation
  3. When you finished the update, simply run composer require mailchimp/mc-magento2:102.3.37 (for know what version you must install visit https://github.com/mailchimp/mc-magento2/releases and search for the version that fit your magento version)

That's all

|improve this answer|||||
0

We have issue with ebizmarts MC for magneto 2.3. we recently upgraded from 2.2.7 to 2.3.3. after that email are not sent and Cron jobs get sql error. Currently version of MC is 1.0.28, is this wrong? Should I install MC V102.3.37?

|improve this answer|||||
0

You should remove module Ebizmarts\MailChimp and re-setup the version

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.