0

I want to update the payment module Dotpay to 1.0.15 - require PHP Version 7.1+

So I run command with PHP 7.1:

composer71 require dotpay/magento2-payment:1.0.15

But during update I received issue:

Problem 1
- scommerce/googleremarketing 2.0.1 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.29) does not satisfy that requirement.
- scommerce/googleremarketing 2.0.1 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.29) does not satisfy that requirement.
- scommerce/googleremarketing 2.0.1 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.29) does not satisfy that requirement.
- Installation request for scommerce/googleremarketing 2.0.1 -> satisfiable by scommerce/googleremarketing[2.0.1].

Installation failed, reverting ./composer.json to its original content.

So it looks like other module scommerce/googleremarketing is not compatible with PHP 7.1+ and I can't update the Dotpay module.

How can I solve this?

  • Try composer require scommerce/googleremarketing. See if you can get a newer version. – Dominic Xigen Oct 29 '19 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.