I am trying to upgrade from Magento 2.2.8 to 2.3.3 and when I run the command

composer update

then I am getting this error

  • symfony/process v2.0.9 conflicts with symfony/console[v4.1.0].

What is the solution?

2 Answers 2


this issue was already addressed earlier: https://magento.stackexchange.com/a/253047/55044

You have to make sure your composer.json file has correct dependencies for magento 2.3


I was in the same problem and I already fixed it. Run this command:

composer config preferred-install dist
composer config sort-packages true
composer config prefer-stable true
composer require --dev friendsofphp/php-cs-fixer:~2.10.0 --no-update
composer require --dev sebastian/phpcpd:~3.0.0 --no-update
php -r '$autoload=json_decode(file_get_contents("composer.json"), true); $autoload["autoload"]["psr-4"]["Zend\\Mvc\\Controller\\"]= "setup/src/Zend/Mvc/Controller/"; file_put_contents("composer.json", json_encode($autoload, JSON_PRETTY_PRINT|JSON_UNESCAPED_SLASHES));'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.