1

I hope you can help me with this issue.

I already enabled the maintenance mode and set up the IP filter, but it's not working. Although I configured to access the site with my IP I'm unable to see front-end and back-end, I only get the 503 Error page.

I used all the common commands for the manintenance mode and even tried to configure a redirection through .htaccess with IP filter and doesn't work either.

Thank You.!

2
  • you have redis cache setup? Oct 24, 2019 at 4:46
  • I have redis cache enabled. Is there any configuration which must be done regarding it?
    – Raül
    Mar 7, 2021 at 20:58

1 Answer 1

1

First step:

Run php bin/magento maintenance:allow-ips 127.0.0.1 where 127.0.0.1 your IP

Second step:

Check on your_site_path/var folder .maintenance.ip file. Thes file should contain allowed IPs by comma-separated. If you didn't see it create this file manually and run: php bin/magento maintenance:enable also, Magento should be switched to production mode

3
  • Thanks for the answer. Already tried this and it's not working although the IP is being saved in the .maintenance.ip file. What can I do to make it work. Is there any other command I can use or any other configuration I should check?
    – msrz85
    Oct 28, 2019 at 20:16
  • Did you switched Magento to production mode? You can also use a custom FREE extension like this one mageplaza.com/magento-2-better-maintenance/…
    – Sergey Y.
    Nov 1, 2019 at 12:03
  • @msrz85 did you manage to exempt your IP? I'm struggling with the same situation.
    – Raül
    Mar 7, 2021 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.