0

I'm posting this question again since all the existing related posts are pretty old! I am completely new to Magento and I had just started to change a few config settings when I started to get a 404 on the admin. Site loads fine it's the admin I have issues with. I was setting up stores fine but I changed a Base URL (secure) saved and got a 404 afterwards. I have no idea whatsoever how to fix this and I need my admin back! I appreciate all the help I can get! Thanks,

  • Hi, Can you please check is there any .htaccess file available on your project root directory ? – Kishan Savaliya Oct 21 at 3:59
  • Yes, there is an .htaccess file. – Cecilia Paolucci Oct 21 at 15:03
  • Did you enabled URL rewrite ? – Kishan Savaliya Oct 21 at 15:09
  • im not 100% sure but im pretty sure I didn't, since I was changing settings just to see the results. I never imagined there was a config change that would prevent me to go back to the admin and change it back! – Cecilia Paolucci Oct 21 at 15:15
  • 1
    sure! I really appreciate your help! – Cecilia Paolucci Oct 21 at 15:46
0

Open you Database in phpmyadmin and then select your DB there and run this query there.

UPDATE `core_config_data` SET `value` = '0' WHERE `core_config_data`.`path` = 'web/secure/use_in_adminhtml';

After this please run below commands to clear cache..

php bin/magento cache:clean
php bin/magento cache:flush

That's it. After doing this you can open your admin page.

Hope this will help you!

  • Let me know if this solution works for you or not ? – Kishan Savaliya Oct 21 at 16:04
  • Approve my answer if above solution works for you. – Kishan Savaliya Oct 21 at 16:32
  • it worked! thanks a lot!!! I really appreciate your help – Cecilia Paolucci Oct 21 at 19:28
  • Thanks you too Buddy. Happy to help you! 😊👍 – Kishan Savaliya Oct 22 at 1:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.