0

I have Magento 2.2.8 and I'm not able to install MailChimp in ANY way. I tried the manual installation, but it said:

[ReflectionException] Class Mailchimp does not exist

I tried the installation with the composer in a lot of ways, but it retrieved a lot of warning/exceptions. If I try to install the latest version compatible with my version (101.2.34), the installation goes through, but at the end, I got this error:

The following modules are outdated:
Ebizmarts_MailChimp db schema version: defined in codebase - 101.2.34, currently installed - 102.3.37
Ebizmarts_MailChimp db data version: defined in codebase - 101.2.34, currently installed - 101.2.37 [] []

So I tried to install the version 101.2.37 (which it should be compatible only with Magento 3). Indeed, the installation doesn't go through and I got this error from the composer:

  Problem 1
    - mailchimp/mc-magento2 102.3.37 requires magento/framework 102.0.* -> no matching package found.
    - mailchimp/mc-magento2 102.3.36 requires magento/framework 102.0.* -> no matching package found.
    - mailchimp/mc-magento2 102.3.35 requires magento/framework 102.0.* -> no matching package found.
    - mailchimp/mc-magento2 102.3.34 requires magento/framework 102.0.* -> no matching package found.
    - Installation request for mailchimp/mc-magento2 ^102.3 -> satisfiable by mailchimp/mc-magento2[102.3.34, 102.3.35, 102.3.36, 102.3.37].

I tried to install ALL the previous versions via composer, but it always tells me that the modules are outdated. I tried to run composer update as well, but it didn't fix the problem.

This thing is very annoying and I really don't know how to figure this out. I really need to install MailChimp.

Please, help me! Thanks

0

Alright. This is definitely a bug from MailChimp. I found out that if I change the version from the module.xml, the problem will be fixed.

I basically edit this file:

vendor/mailchimp/mc-magento2/etc/module.xml

And updated this code:

<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Module/etc/module.xsd">
    <module name="Ebizmarts_MailChimp" setup_version="101.2.37">

with the right version (102.3.37), that by the way should be the one not supported for Magento 2.2. This is definitely a bug.

<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Module/etc/module.xsd">
    <module name="Ebizmarts_MailChimp" setup_version="102.3.37">

I don't really know if this is the right way to do that, but it works. Please, let me know if you guys know a better method to fix the issue.

Thanks

| improve this answer | |
0

I think the problem is You installed MailChimp before so your database saved its version.

And then you install a different source that has different version defined in module.xml ( less than the old one) and it caused this error.

Modify the version number can fix it but you should get the newest.

| improve this answer | |
0

I think the problem is that "Mailchimp" and "MailChimp" are not the same.

Chances are the folder name is incorrect, and needs to be matched to the capitalization used in the code.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.