0

I have a problem with magento 2.1.7, every time a guest user subscribe to the newsletter he doesn't receive confirmation email. I have already check on

Configuration > Customer > Newsletter

Configuration > Advanced > Admin

and check the cron job as well. everything is fine but no resolution.

please help.

0
0

There is one condition in Newsletter Email's Model file here..

vendor/magento/module-newsletter/Model/Subscriber.php

if ($this->getImportMode()) {
    return $this;
}

If in this function you will get true as an Import Mode then these all functions will not work for newsletter emails.

  • sendConfirmationRequestEmail()
  • sendConfirmationSuccessEmail()
  • sendUnsubscriptionEmail()

If you are using MailChimp for emails then you will get this issue, Because there is one setting available in MailChimp Configuration.

Store > Configuration > MAILCHIMP > Mailchimp > Mailchimp General Configuration > Magento always manage emails

  • In this setting you need to select "Yes", Because if you will select "No" there then Mailchimp will use Import Mode is Yes. So from Magento Customer will not get any newsletter emails.

  • You can run below command to enable that setting without changing that in configuration.

php bin/magento config:set mailchimp/general/magentoemail 1
php bin/magento cache:clean
php bin/magento cache:flush

Hope this will help you!

0
0

Thanks Kishan Savaliya, I debug for 2 days and at last I found this one. It is exactly what my problem is and after set "Magento always manage emails" to Yes, my newsletter email start send out normally.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.