Magento 2.3.1 installed on lightsail using the official bitnami AWS installer, if you go to the admin, it redirects back to the old website. In the database core_config_data the URLs are correct.

I updated the domain name, I updated letsencrypt, I cleared and flushed Magento cache and restarted everything. Only the admin area is redirecting


You can run this step-by-step to check the possible things.

Run this command to get the Magerun2 to made the changes easier.

wget https://files.magerun.net/n98-magerun2.phar && chmod +x ./n98-magerun2.phar && alias n98="./n98-magerun2.phar"

Run this command to see if there is some additional base URL in your configurations that aren't correct.

n98 config:store:get %base_url%
n98 config:store:get %cookie_domain%

Regenerate all the static content again, reindex and flush the cache.

n98 maintenance:enable
n98 deploy:mode:set developer;
n98 setup:upgrade;
n98 setup:static-content:deploy -f;
n98 setup:di:compile;
n98 maintenance:disable;
n98 index:reindex;
n98 cache:flush;
| improve this answer | |
  • if I run n98 config:store:get %base_url% or n98 config:store:get %cookie_domain% I get pastebin.com/W46Jgcxx – Lynob Oct 18 '19 at 7:07
  • Running the above commands using magento command line tool and running reindexer:reindex fixed it, then I logged in to the admin area and changed the path to the static files – Lynob Oct 18 '19 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.