1

We have migrated customers and orders data from M1 (1.14.3.1 EE) to M2 (2.3.1 commerce) successfully But when we are doing testing at the admin end for the orders found that the Reorder button was missing. Then we checked below scenarios

  1. Reorder settings enabled (System -> Configuration -> Sales -> Sales -> Reorder)

  2. Crated an order in the frontend then it is showing reorder at admin end.

Can anyone have faced this kind of issue could you please advise.

  • Hello @NagarajuKasa the previous was customer credit card related issue... so please check tables for used payment method it will provide some links. because I've never faced this kind of issue. – Aditya Shah Oct 18 at 7:48
1

Have not seen this before in stores that we have migrated so far. But perhaps you could follow the steps Magento 2.3 takes to determine if an order can be reordered or not.

  1. The logged in user needs to have permission to use the reorder function. (I assume this is the case since you can reorder other orders). - Magento\Sales\Block\Adminhtml\Order\View::_isAllowedAction('Magento_Sales::reorder')
  2. The Reorder setting needs to be enabled for the right store view. Were the orders assigned to the correct store view during migration? - Magento\Sales\Helper\Reorder::isAllowed
  3. The order cannot be in "hold" or "payment review" status. - Magento\Sales\Model\Order::_canReorder()
  4. The order cannot have the reorder flag set to false. This is not something the core would do, but a module might. - Magento\Sales\Model\Order::_canReorder()
  5. All ordered products in this order must exist in the store. This is perhaps the most important condition, and a most likely cause. Check if your imported orders have the correct product_ids linked in the sales_order_item table. And that these products exist. - Magento\Sales\Model\Order::_canReorder()
  • The order has been migrated with the on-hold status we would like to process on m2. & the live credentials were not yet set up on m2. (Magedelight CyberSource orders) – NIPPU Oct 17 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.