4

I can't open simple products.. keep getting error as below, tried disabling Temando_shipping..

no joy.. any ideas to resolve?

1 exception(s):
Exception #0 (ReflectionException): Class Temando\Shipping\Model\Source\PackagingType does not exist

Exception #0 (ReflectionException): Class Temando\Shipping\Model\Source\PackagingType does not exist
<pre>#1 Magento\Framework\Code\Reader\ClassReader->getConstructor() called at [vendor/magento/framework/ObjectManager/Definition/Runtime.php:49]
2 Magento\Framework\ObjectManager\Definition\Runtime->getParameters() called at [vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php:48]
3 Magento\Framework\ObjectManager\Factory\Dynamic\Developer->create() called at [vendor/magento/framework/ObjectManager/ObjectManager.php:56]
4 Magento\Framework\ObjectManager\ObjectManager->create() called at [vendor/magento/framework/Validator/UniversalFactory.php:36]
5 Magento\Framework\Validator\UniversalFactory->create() called at [vendor/magento/module-eav/Model/Entity/Attribute/AbstractAttribute.php:641]
6 Magento\Eav\Model\Entity\Attribute\AbstractAttribute->getSource() called at [generated/code/Magento/Catalog/Model/ResourceModel/Eav/Attribute/Interceptor.php:1181]
  • Having a same issue, after rolling back from 2.3.3 update to 2.3.2 – crashtestxxx Oct 17 '19 at 5:48
  • can you please enable of Temando shipping module after flush and check – Vishal Baraiya Dec 6 '19 at 5:22
5

You can remove generated directory using this command, because you've disabled that module but some code which is generated in generated/code/ directory which is still available there. So you need to remove that first.

rm -rf generated/

and then just run upgrade command if you are using developer mode. Otherwise run all deployment commands there and then check again.

If you're using developer mode in magento then run below command

php bin/magento setup:upgrade

Otherwise run below commands

php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy -f

If that will not work then you can try this steps...

Go to your database and search eav_attribute table, there may be some attributes available which are using Temando model classes there.

So you can search in this fields source_model like Temando

You can see this output :

enter image description here

and then remove that Temando attribute there or you can set NULL value for that attribute or you can unassign all three Temando Shipping module's attribute from backend (Store > Attributes > Attribute Set) and just clear cache.

Hope this may help you.

  • when I run below commands Temando folder is recreated in generated folder & same error php bin/magento setup:upgrade php bin/magento setup:di:compile – Nathan Oct 15 '19 at 10:11
  • Can you please run this command and check your module disabled properly ? php bin/magento mo:d Temando_Shipping. If your module properly disabled there then you'll get this message "No modules were changed.". – Kishan Savaliya Oct 15 '19 at 10:15
  • Otherwise try to enable that module first and run this command to disable that module. php bin/magento mo:d Temando_Shipping --clear-static-content – Kishan Savaliya Oct 15 '19 at 10:18
  • still same error.. – Nathan Oct 15 '19 at 10:28
  • 2
    Replacing source_model column values where it contains Temando at eav_attribute fixed my problem. I just don't get it, why open source Magento framework trying to force us to these useless, nothing but the trouble, lame modules. – crashtestxxx Oct 17 '19 at 6:29
2

Try to remove ts_ prefixed attributes from Default attribute set (Store / Attributes / Attribute Set): enter image description here

0

Please try to do with below command :

rename your "generated" directory in root...

php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy -f
php bin/magento cache:flush

Than check...

  • thanks will try, as soon as I rename though another 'generated' folder is created & .htaccess is not regenerated inside the folder – Nathan Oct 15 '19 at 10:42
  • The temando folder is created inside the generated folder when the php bin/magento setup:di:compile command is run – Nathan Oct 15 '19 at 10:44
  • Still same error – Nathan Oct 15 '19 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.