0

For my Magento2 website I have created a custom module and layout for products. I have assigned that custom layout for that product from product edit design section. And from that layout, we are calling the particular module phtml files. This functionality works on localhost as well as staging website but on Live website this functionality not work. On frontend product loaded the default 1 column layout.

New Layout.xml code path : vendor/magento/module-theme/view/frontend/page_layout/

<?xml version="1.0"?>
<layout xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_layout.xsd">
    <update handle="empty"/>
    <referenceContainer name="page.wrapper">
        <container name="header.container" as="header_container" label="Page Header Container" htmlTag="header" htmlClass="page-header" before="main.content"/>
        <container name="page.top" as="page_top" label="After Page Header" after="header.container"/>
        <container name="some.container" as="someContainer" label="Some Container" htmlTag="div" htmlClass="some-container" />
        <referenceContainer name="some.container">
            <block class="Configurator\ProductBedz\Block\Display" name="produtctsbedz_display" template="Configurator_ProductBedz::jsonconfigurator.phtml" />
        </referenceContainer>

        <container name="footer-container" as="footer" before="before.body.end" label="Page Footer Container" htmlTag="footer" htmlClass="page-footer"/>
    </referenceContainer>
</layout>

Can anyone let me know what is the issue and how to solve this issue on live website. The same code is working on my localhost and staging website.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.