0

I have an extremely weird problem that I face for the first time.

From time to time (it's really absolutely random), the CSS of a Magento 1.9.3.10 store is not fully loaded. It can happen on a product page or catalog page, and even home page.

Basically, on every 100~ requests (refreshes), the CSS does not load fully. The weird part is that in the console I see that the response is 200, the CSS is loaded but it's 6kb when the full file is 80kb~. When I open the CSS file, I see that it is interrupted but it's in a weird place and where there are no special signs or anything. If I click refresh, it loads it correctly.

The same behavior goes for the whole website and the team is totally out of ideas.

There are no registered errors on the server, nor the console. Everything returns 200, everything is loaded and yet - the CSS file is interrupted. Also, every time the file is interrupted in a different place, so even this happens at random.

The team considers that this is a server issue, but there are no errors or anything on the server (nor a serious load). Our current setup is in AWS (been there for a year) and we never faced such problems.

All that happen after we switch to a new theme with bootstrap (because the previous one wasn't) and we installed a new slider (revolution).

Also, this happens only when the CSS is merged if we don't combine the CSS files, everything loads flawlessly.

Can anyone assist me with that or has anyone see such a thing?

  • Has anyone faced such issue? I would really appreciate any help and/or advise. – Martin Konstantinov Oct 24 at 13:22
  • I had the same issue in the past. I think I fixed this by fixing some CSS errors. Try css validators like W3.org for your CSS files. – TonkBerlin Nov 12 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.